Scanning does not find any bluetooth devices

hej all!

scanning for bluetooth devices (both thru blueman and bluetoothctl) does not yield any results. no devices discovered, though 5 devices in range, phone able to see other devices.

i start bluetooth.service manually, so bluetooth not being on cannot be the issue. adapter is discovered by the system and had no issue prior to my previous system upgrade

running endeavouros sway community edition on t460s

thanks in advance – i know i most likely broke something, but this time i seem to be unable to fix it

1 Like

i feel this might be useful for some reason,

>$ rfkill list

0: tpacpi_bluetooth_sw: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Did you check if the bluetooth service is running?

systemctl status bluetooth


of course,

● bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/syst>
     Active: active (running) since Sat 20>
       Docs: man:bluetoothd(8)
   Main PID: 1319 (bluetoothd)
     Status: "Running"


5 devices in range and it doesn’t pick up any? I find that hard to believe. Have you used bluetoothctl and gone through the steps to power on, turn scan on, discoverable on, pair, connect, trust etc?

yes, absolutely. the other important bit is that it worked previously without any major issues, except for one hiccup found here:

It could be newer firmware or kernel or something else?

What is your bluetooth hardware.

inxi -Na

inxi -Na

  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:156f class-ID: 0200
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24f3 class-ID: 0280
  Device-3: Intel Bluetooth wireless interface driver: btusb type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:3 chip-ID: 8087:0a2b
    class-ID: e001

some more helpful details

  Device-1: Intel Bluetooth wireless
    interface driver: btusb type: USB
  Report: rfkill ID: hci0 state: up
    address: see --recommends

Are you dual booting with Windows?

no, clean install of eos

in attempt to resolve potential conflict

systemctl stop blueman

lead to

Failed to stop blueman.service: Unit blueman.service not loaded.

attaching screenshot

after “devices” is entered in bluetoothctl, nothing shows up

same issue through blueman-manager

[bluetooth]# discoverable on
Changing discoverable on succeeded

your turn off ( in screenshot )

changed to

 Discoverable: yes

however, problem still persists.

important to note that status currently is

[CHG] Controller 44:--:--:--:--:-- Discovering: no

(dashes added for anonymity)

my other devices can see my computer, but computer cannot see other devices

there have been a lot of reports about bluetooth not working since kernel 6.4.0, try the lts kernel

1 Like

i will keep this in mind as an emergency solution in case no other is found

meanwhile will keep digging and post if anything works out

Can’t stop it if it isn’t loaded. Don’t you need blueman running?

Edit: Have you gone through the wiki and checked everything.

did you try

[bluetooth]# scan on
Discovery started

just ask.

if have another usb bluetooth adapter could plug that in .

i alway carry in bag usb bluetooth + usb wifi adapter for time like this ( problem with built in wifi/bluetooth after update)
it nature of the beast

Have you tried turning off the bluetooth devices and then turning them back on. Bluetooth is very finicky and sometimes the simplest thing makes it work.