Scaling problem on the ISO

I was just trying to test the new April release, and the screen resolution is huge! I checked the md5sum and I have a good ISO. I never had any issue with 2019.12.22 version. Any ideas?

Hello @fhins
What is the dpi setting under appearance fonts? What is your normal resolutions settings on what type and size of monitor?

Edit: Not sure what the dpi is set at but if you change it say 3 or 4 down and go out of it and then go back in and set it back usually it will change the font sizing.

It’s a 23 monitor and 1920 x 1080 resolution. This is my test computer, and have 4 SSD hard drives. I already have Manjaro, Arco, and eOS (2019.12.22 version) installed. I’ve never run into this issue before. The eOS 2019.12.22 version works like a charm, so there is something wrong with the resolution settings.

What does it say for the dpi?

Edit: I’m waiting for you to tell me what the Dpi is? It is under appearance, fonts.

I’m on KDE. I don’t see Appearance/fonts. I see Noto Sans 10pt.
Here’s the inxi info:

System:
  Host: Endv Kernel: 5.4.31-1-lts x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: KDE Plasma 5.18.4 Distro: EndeavourOS 
Machine:
  Type: Desktop Mobo: Gigabyte model: B85M-D2V v: x.x serial: <filter> 
  BIOS: American Megatrends v: FC date: 06/19/2014 
CPU:
  Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell 
  rev: 3 L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 63852 
  Speed: 2295 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 2294 2: 2295 3: 2299 
  4: 2293 5: 2299 6: 2299 7: 2296 8: 2295 
Graphics:
  Device-1: AMD Caicos PRO [Radeon HD 7450] vendor: ASUSTeK driver: radeon v: kernel 
  bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.8 driver: radeon FAILED: ati 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz, 1280x1024~60Hz 
  OpenGL: renderer: AMD CAICOS (DRM 2.50.0 / 5.4.31-1-lts LLVM 9.0.1) 
  v: 3.3 Mesa 20.0.4 direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.4.31-1-lts 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte 
  driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 64.86 GiB (27.2%) 
  ID-1: /dev/sda vendor: Toshiba model: THNSNF256GCSS size: 238.47 GiB 
Partition:
  ID-1: / size: 233.05 GiB used: 64.75 GiB (27.8%) fs: ext4 dev: /dev/dm-0 
  ID-2: /boot size: 689.0 MiB used: 116.2 MiB (16.9%) fs: ext2 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 35 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 215 Uptime: N/A Memory: 15.60 GiB used: 556.1 MiB (3.5%) Init: systemd 
  Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 inxi: 3.0.37 

Give me a minute to look at kde . I’m not sure where to look also as i was referring to xfce.

So my question is do you already have kde installed and that’s where you are looking because what i wanted was for you to look when you were running the online installer.

Edit: Or are you saying you have a problem with the installed setup?

Yes, I already have eOS installed on this computer. I was trying to test the new ISO on the 4th SSD hard drive. There is no problem with my system, but I’m sure something wrong with this new ISO, because the 2019.12.22 version works just fine on the same computer!

Okay so this is what i’m trying to tell you. Start the computer on the new ISO. When it comes up do not start the installer. First go into appearance, fonts and check what the dpi is. Then lower it about 4 and go out of the appearance settings. Then go right back in and change it back to what it was. I’m assuming it should be around 96 for 1920x1080. Then start the online installer and see if the sizing is correct. Let me know.

Okay, under system > display, maximum resolution that I can chose is 720 x 480.
Under appearance > fonts, it’s set on Noto Sans regular 10.
It doesn’t give you any option more than 720 x 480 to chose from, so that’s the problem, and that’s what needs to be fixed. Again, the previous ISO works great!

@fhins
When you boot on the ISO it is Xfce so you should be going into appearance, fonts and changing the dpi not the resolution! The dpi should be set around 96 but that doesn’t matter so much as just the fact that you change it and go out then go back in and set it back then start the online installer. I didn’t want you to change resolution. I said the dpi setting because i’m trying to determine if the font sizing is correct after you do that with the online installer. I had this issue during testing. Also are you using todays ISO that just was put out?

Edit:
The issue isn’t there on the new ISO but i did run across it in testing on one of the other ISO.'s This is why i’m asking you to confirm.

Here is a screen print of the appearance settings, fonts, DPI.

It’s the DPI setting that I’m asking you to change temporarily and then go out and back in and set it back. Then start the online installer. The resolution you can’t change there. It only gives one size and you can’t change that.

It’s exactly like your screenshot. Custom DPI setting is at 96. Default Font is Noto Sans Regular 10. Monospace Regular 10 also.
Also changing the DPI setting doesn’t make much of a difference. I think it has to do something with the Grahpics. As you see I have a AMD Radeon HD 7450 which works well with any Linux distribution. I have that same GPU in all my doezen computers at home, work and etc. What did the 2019.12.22 version used, as there is no such issue with that ISO.
One observation; When you first start booting the ISO, the initial writings on the screen switches to smaller fonts automatically on the 2019.12.22 ISO. How ever, this one it does 't. Also the graphics on the screen gets scrambled for a second and then it goes to a gray screen and after that the eOS logo loads up where you see the huge screen. Another indication that it may has to do with the GPU.

Yes, you are right on booting the ISO on an older AMD Radeon HD 7450 as i have two of them so i know what you talking about there. But on the booting of the ISO when changing the DPI what i found is this.

If the font is the wrong size when you launch the online installer the trick is to do the following. Close the online installer and go into appearances and change the dpi and go out of it. Then go back into it and set it back. Then usually the font sizing corrects itself. Just changing it doesn’t work and you won’t see any visual change unless you go out and back in and set it back and then launch the online installer. If this doesn’t work for you then i don’t know if we are referring to the same thing or it’s not working for you. I’m only relating it to when it’s fully booted on the ISO and you launch the online installer and font sizing is too small or too big.

Everything else you describe about the boot is a Graphics issue when it scrambles for a second before the grey screen and then loads the desktop. That is coming from the built in kernel drivers for the AMD graphics. It happens on both my older AMDRadeon HD 3870 and also the HD 6450/7450 cards. It doesn’t happen on my new Radeon RX590 system.

Hi
As per your problem i think it may be related to HiDPI Scaling.
Can you check https://wiki.archlinux.org/index.php/HiDPI and adjust your scaling. Its a suggestion only. Thanks

That’s not the problem. As I mentioned there are 4 SSD hard drives on that computer, and I have 3 OS already running on it, including eOS. I’ve tested just about all KDE distributions on it without any issue. I can even use the 2019.12.22 ISO without any problem. Again I think it has to do with the GPU, but what do know!

Hi!

I’m curious to know if some video driver may not be present in one of the installs.

Can you give the output of pacman -Q |grep xf86 for the install that work and the one that doesn’t (after install, not the live environment)

Since you have AMD i expect you to have xf86-video-amdgpu and xf86-video-vesa at least.

Something is wrong ? When I boot the ISO I get “frequency out of range - please change display mode” and monitor shuts down. A friend of mine called me and has the same problem. Radeon HD 5000/6000/7350/8350.

I noticed the AMD issue also on my older Amd Radeon HD series from 3870 to 7450. Although i was able to boot on the ISO i was also seeing the screen get scrambled but it gets past it and the grey screen comes up to the desktop. I am not getting it on my newer AMD Radeon RX590. The Font sizing in the online installer screen is related to DPI as i also had that and was able to correct that issue by going in and out of dpi settings with a slight change and then back again it seems to adjust to the correct font size. This is strictly on the online installer slides that i am referring to. Resolution seems to be preset by the Calamares installer. That’s my experience with it. :neutral_face:

2 Likes

I did exactly that, but unfortunately it didn’t make any difference in this case. I hope eOS team work on this and come up with a solution, and for the time being make the 2019.12.22 download available, because that one works just fine!