Scaling issues on my Dell xps 13 9380

Hello Endeavor pros,
I just installed (as of last night) and am having issues with my screen resolution. I am having trouble with scaling. Whenever I restart or log back in after being logged out the screen is all messed up and only showing on a quarter of the screen. I have to manually change it back in the settings every time. Is this because I have a 4k screen? Any help for this or is Endeavor not going to work out for me? I’m a newbie, just switched from Solus because the battery life was still bad for me.

Thanks so, so much for your insights and help!

-linny

Hello @linny
Welcome to EndeavourOS. Could you provide some hardware info maybe start with inxi -FGz
You may have to install inxi first.

Also what desktop have you installed would be helpful.

1 Like

Thanks @ricklinux! I hope I’m doing this right, I’ve never used pastebin before. :slightly_frowning_face:
https://pastebin.com/0vqHXjHu I am running Budgie desktop. :slight_smile:
thanks!

You said this the model with 4K display so it is Hidpi i assume? Budgie is based off gnome so i’m not sure where or if it has settings somewhere to set scaling. In gnome it is done through gsettings? I am going to have to defer to one of my colleagues who is more knowledgeable in this area and on Budgie desktop as i don’t want to lead you astray and cause you any issues. I will leave you with some info from Arch on HiDpi for now so you can have a look at it. I’ll see if i can do some research.
They don’t specifically list Budgie but other desktops have settings.

https://wiki.archlinux.org/index.php/HiDPI#GNOME

Edit: Supposedly Budgie doesn’t support fractional scaling so you have to adjust the Font size but I’m not sure this is your isssue? Is it Blurred text or is it just a resolution problem? I think maybe @dalto may be able to help here.

1 Like

No the font is fine, its just that when I log back in or restart the screen is all messed up. Everything is either super tiny, or only showing up in the top left quarter of the screen and everything else is black. I believe it is hidpi? I bought it refurbished on ebay so I’m not 100% sure, its the infinity edge touch display, 4K. So I’m assuming so. Any help is appreciated. Thanks for everything so far. :slight_smile:

Edit: If Budgie doesn’t support fractional scaling do you think I should try a different desktop environment? What do you recommend and how do I switch?

That doesn’t sound like an issue with fractional scaling to me.

budgie generally autoscales pretty well and you can tweak it with font sizes from there.

In your case, I can’t help much but it sounds more like something odd with resolution detection or your video drivers. graphics drivers really aren’t my area of expertise.

As a heads up, you don’t seem to be running at 4K, you seem to be running at 1440p. Have you tried settings the resolution to 4K?

Have you tried the LTS kernel to see if it is something specific with the drivers? I know that i915 drivers have been a bit weird lately.

I don’t think it actually is an issue with budgie but if you want to switch I would try either KDE or Gnome+wayland. I suspect all the gtk3+X desktops(mate/budgie/cinnamon/etc) will all have the same problem. Either way, I think that should be your last resort.

1 Like

@linny
Have you tried to set the resolution higher? If it will do it?

Edit:

The dell site say’s some infinity display may be 3840x 2400 and others are 1900x1200 so maybe you should look up the info using the service tag on the laptop if it’s there .

1 Like

Sorry for the poor resolution photos, I was having trouble. Hopefully this helps illustrate my problem better, its only showing up a quarter of the screen.

I was even having trouble with Solus when I first installed on this laptop, so I’m starting to wonder if its something wrong with the video driver or graphics card like you said… :frowning: I’m still stumbling in the dark here. I just got this new laptop, for the express purpose of installing Linux, and now all of these roadblocks. lol oh well, it’s all a learning experience. How do I change the settings to 4K? I went into settings and tried to fiddle with the resolution, but its still hit or miss…

What is the output of this command?

xdpyinfo | grep -B2 resolution

1 Like

xdpyinfo | grep -B2 resolution
screen #0:
dimensions: 2880x1620 pixels (762x429 millimeters)
resolution: 96x96 dots per inch

So i don’t think this is a resolution problem but something else. How was the live ISO displayed?

1 Like

it displayed fine, but it was very tiny and hard to see, so I had to mess with the resolution to get it bigger. Certain apps still display very tiny for me. Steam in particular.

This is what seems to show up best right now, and I have to manually reset it every time I log out or restart. Annoying.

Don’t change the resolution to make things bigger. Use scaling for that.

I would set the resolution back to 4K and see if consistently fills the screen. If it does, we can fix the scaling issue so things aren’t tiny.

The fact you are setting an non-native resolution is going to cause things to be less clear.

1 Like

Since he purchase this laptop used and is unsure if it is 4k or not i would go to the dell site and enter the service tag and find out exactly.

1 Like

@linny
You could use this command and it will tell you the supported resolutions.
xrandr --prop

1 Like

I’m a lady actually. :wink: But I did manage to find that is indeed 4K. 13.3" 4K Ultra HD (3840x2160) InfinityEdge Touch Display.

Sorry Linny … So if you tried to set the resolution to that does it make it even worse of a problem?

1 Like

I put the resolution all the way as high as I had settings for in Budgie. Which turned out to be 3840x2160 and then I scaled up to 200% but it still seems a bit small to my eyes. If I go to 300% its too big, i wish I could set it to 250% but there’s no option.

Edit: when I log out or restart it still only shows in the top left quarter of the screen.

I don’t know what to tell you other than it would be interesting to know if this happens on other desktops too? It might be worth trying Cinnamon or Xfce?

Edit: According to the Arch wiki page Cinnamon has good support out of the box for HiDpi. Xfce supports HiDPI scaling which can be enabled using the settings manager:

https://wiki.archlinux.org/index.php/HiDPI#Cinnamon

1 Like