Running ONLY Legacy Bios Boot, MBR HDD , win7

Installing Endea into an empty partittion which was squeezed out from existing Window7 partition.
Sda1 original win7 boot partition
sda2 win7
sda3 endea

Have you set the boot or esp flag on your boot partiton?
The problem’s probably more than that but just in case it is!

From your live usb, post the output of the:

sudo parted -l

It looks like you are doing an UEFI installation on a disk that has already a Legacy/MBR installation on it.

You could boot up your live usb in Legacy mode and when installing choose the disk /dev/sda and not a partition (like you have done, /dev/sda1) for the installation of the bootloader.

I let kalamare does it all automatic… i just select a partition that it can overwrite… i didn’t do anything else. i thought it will auto do what it needs to do … it can’t automate ?

I don’t want to do anything that will ruin the existing win7 boot up. will that causes win7 boot up issue later on ? (i know it can be easily fix… but a way around it to save me some trouble ? )

It is not artificially intelligent no. It defaults to EFI usually. It looks like you need to change that to MBR It is the round cog at the beginning of the installer.

Okey.

What I told you is the normal procedure to make a dualboot in Legacy mode.

Make sure you make a recovery disk in Windows before installation if you ever need to recover Windows’ MBR.

Let me repeat again what i have received:
Endea installer is default o UEFI instead of Legacy.
In order to have both os to run without hassle, both should be the same Legacy or UEFI… in this can since it is already in legacy, then i should some how change the endea installation to use legacy instead of UEFI… How do it do that ? there is no option for me to choose that.

sda1 which flagged as boot partition is NTFS… how can you tell this is legacy ? is it “partition table: msdos” that gives away that it is legacy ?

I can’t work with pictures. If you insist on doing so the least you could do is clean that screen :laughing:

4 Likes

No, but the lack of an ESP (EFI System Partition) which is formatted as FAT32 and carries the boot flag and usually the esp flag as well.

Having an ESP is not optional for an installation in UEFI mode. It is a requirement.

And please post the outputs as text, highlight them and click </> button to format.

:flushed: it is the light reflection that makes the dust particle “pop out”. Air beside road here is dusty…
I can’t paste it out, because these are 2 separate pc.

  • first UEFI always require GPT and /boot/efi with flag boot&esp
  • you have success to boot in EFI endeavourOS
  • you cant install on a MBR partition in this case

be careful to you change that , need to save data ( all disk ) before format GPT , and also reinstall windows first

1 Like

Why this when the installer supports installation in Legacy/MBR too?

check carefully under boot :
if you see UEFI: < USB vendor name >< partition 1> boot install efi
if you see < USB vendor name > boot in old bios

@pekab ask Calamares Team

Only the boot flag is required for EndeavourOS calamares.

I am not use to this:
hence need to ask a few question to clarify


Q1: What is this interface ? is it kalamare ? or what does it call ?

Q2: the Red color circled EFI… what does that mean ?

Does it means that my laptop is in EFI mode instead of BIOS mode ? or it means that this linux os needs EFI mode, hence i need to match my laptop to EFI mode in order for it to be install successfully. ?

Q3: the red color circled MBR… what does it means ? Does it means my Hdd has MBR (instead of GPT) ?

Q4: Since @Stephane said UEFI always require GPT… than from this screenshot alone; EFI MBR … this already does not pass!

Sorry, can you tell me check where ? refering to your "check carefully under boot "|
I just checked, my laptop bios setting… there is no “efi setting” or anything efi related … maybe the laptop is older hardware, where EFI is not introduce yet.

My hdd has MBR. i checked from within windows tool

https://forum.endeavouros.com/t/root-linux-dual-boot-windows/7770

 BIOS
a. Select unpartitioned space → Create
b. Size → input 32
c. Filesystem → select unformatted
d. Flags → check bios-boot → OK 

According to the instruction of the above link.

I need to create 3 partitions for linux installation.
1 partition 32B for “Bios-boot”
1 partition for /home ext4 mountpoint /
1 partition for /swap

but windows os has already taken 2 of the partitions away from my MBR HDD.
Q1.
Can i put 32B Bios-boot partition as primary
create extended partition for /home and /root
create a logical partition in the above extended partition for /swap ?

will this work ?

Q2.
Or can i put the 32B bios-boot in logical partition ? and put /swap in primary partition instead ?
Q3.
What is the 32B bios-boot partition for ? How does it works with the existing MBR of the HDD ?

Thx

  • check before your bios is updated
  • do a backup before

try to see how convert a MBR disk under windows 7 to GPT

  • it will create 300Mo /boot/efi

  • add UUID for each partition

  • if it is a 32 bit EFI motherboard , it’s not simple to boot on 64 bits cpu

can you return from USB iso Endeavouros,
open a terminal and return

inxi -Fza

Hi Stephane, Merry Christmas.
You meant check my bios and do a backup of bios ? my bios don’t have EFI feature… old hardware… do you think it run GPT partition scheme ? pls explain… i don’t get it. thx