Right click menu flickers and gone

Anybody having problem with linux system that when right click , the right click menu just flicker and gone before you can even click one of the menu.
Or I think a more clear description of the issue is: right click menu appears less than a second then gone.

This happens mostly on dolphin file manager; the menu appears and gone in less than a second for several times before the menu stay visible, each time i right click on a different things.

It happens on firefox too, but not all the time.

I think this happen on a lot of distro.

If this happens reliably then it could be an issue with your mouse/touchpad button.

The switches wear out and can start misbehaving - I have a mouse and a trackball which will occasionally double-click when I want to single-click.

The way to test this is to use a different device, and if this is the reason then you can either replace the switch (if you have a soldering iron) or it’s time to put that mouse outside… :frowning:

5 Likes

I thought there already was a problem with the mouse not scrolling and changed the mouse. Must have some bad mice here. :wink:

Edit: :computer_mouse: :point_left:

I did put the mouse with scrolling wheel issue aside. This is my Logitec cordless mouse which i use on the other desktop. To tell you frankly, this mouse have no issue or whatever on windows os… i personally think it is linux os that is overly sensitive.

Have you changed the batteries for fresh ones?

4 Likes

Nope. Not once ever on any distro in a number of years. As suggested, if your mouse is moving and working otherwise, change the batteries or replace your mouse.

1 Like

I do have the same behaviour here. I’m using KDE. If it happens, most of the times I do have to click three times to get it working. Renewing battery didn’t solve the issue.
I haven’t tried yet if it’s the same issue when using another desktopenvironment. When I have time left, I’ll dig in a little deeper.


lsusb
Bus 003 Device 004: ID 24ae:1100 Shenzhen Rapoo Technology Co., Ltd. 

It started immediately after a KDE update. Unluckily I don’t remember which version change introduced that behavour. Maybe it was just a coincidence. There is always some other stuff updated when KDE updates are available.

2 Likes

I have been running KDE also and i have never seen this. My right click is solid as a rock.

I too have never had any problems with mice on Linux, apart from those that were of hardware nature (like a broken USB cord that randomly disconnects).

The only problems I’ve ever had with mice was solved by fresh batteries.

Yes, I did. I changed the battery last night, because low batt indicator was on.
And the right click menu happened this morning.

1 Like

It is just random occurance. I have the same issue on manjaro as well.
Now i tried the same mouse and same action on same dolphin and firefox browser, the right click menu is all ok … no more flickering and gone. It FIXED itself.
That’s why i said linux is buggy here and there a bit, could be with certain hardware and certain laptop.

What about changing compositors in KDE?

System Settings > Display and Monitor > Compositor and change the Rendering Backend to 3.1, 2.0 or XRender and hit Apply and see if that is the issue.

2 Likes

Am I reading this correctly?

1 Like

I changed the battery last night… the problem (right click menu issue) occurs only this morning, if i remember correctly (very forgetful).
It is night here now… my computer has being in suspended mode whole day… now it is FIXed by itself… … Now my right click is also Solid like Rock!
What can i say ? nothing. :zipper_mouth_face:
My touchpad on/off toggle issue also not the first time appeared… it also solved by itself last time… until now it happened agan! :see_no_evil:

2 Likes

Ok. Thanks… that might well be a solution. I have noted down this possible solution … if it ever happened again. I will try it and feedback the result here.

Thanks.

Just currious… does this changing compositors in KDE able to be done in Terminal command ?
I remember Linus Torvalds said, he does not even bother which distro to use, to him all linux are the same. I am guessing what he meant was, he can use Terminal command to achieve all that we do on GUI, because it is quite the same in command line mode.

There are something i rather do it in command line instead… because it is easy to “locate”. GUI sometime i troublesome, because user have to locate where the options are located, and that’s is an issue as well…

1 Like

I am a GUI person myself, but to answer your question, I think in KDE/5 you have to setup a rule to block the compositor.

qdbus org.kde.KWin /Compositor suspend
qdbus org.kde.KWin /Compositor resume

To my knowledge, there is not a simple CLI command to switch/shutoff. Personally, it would be easier to just use the System Settings, but :man_shrugging:

1 Like

:sweat_smile:
Ya, in this case you are right.

$ qdbus org.kde.KWin
/
/ColorCorrect
/ColorPicker
/Compositor
/Effects
/KWin
/Screenshot
/Scripting
/Session
/VirtualDesktopManager
[enos-andrew@enos-andrew-pc ~]$ qdbus org.kde.KWin /Screenshot 
signal void org.kde.kwin.Screenshot.screenshotCreated(qulonglong handle)
method QString org.kde.kwin.Screenshot.interactive()
method void org.kde.kwin.Screenshot.interactive(QDBusUnixFileDescriptor fd)
method void org.kde.kwin.Screenshot.interactive(QDBusUnixFileDescriptor fd, int mask)
method QString org.kde.kwin.Screenshot.interactive(int mask)
method QString org.kde.kwin.Screenshot.screenshotArea(int x, int y, int width, int height)
method QString org.kde.kwin.Screenshot.screenshotArea(int x, int y, int width, int height, bool captureCursor)
method void org.kde.kwin.Screenshot.screenshotForWindow(qulonglong winid)
method void org.kde.kwin.Screenshot.screenshotForWindow(qulonglong winid, int mask)
method QString org.kde.kwin.Screenshot.screenshotFullscreen()
method void org.kde.kwin.Screenshot.screenshotFullscreen(QDBusUnixFileDescriptor fd)
method void org.kde.kwin.Screenshot.screenshotFullscreen(QDBusUnixFileDescriptor fd, bool captureCursor)
method void org.kde.kwin.Screenshot.screenshotFullscreen(QDBusUnixFileDescriptor fd, bool captureCursor, bool shouldReturnNativeSize)
method QString org.kde.kwin.Screenshot.screenshotFullscreen(bool captureCursor)
method void org.kde.kwin.Screenshot.screenshotScreen(QDBusUnixFileDescriptor fd)
method void org.kde.kwin.Screenshot.screenshotScreen(QDBusUnixFileDescriptor fd, bool captureCursor)
method QString org.kde.kwin.Screenshot.screenshotScreen(int screen)
method QString org.kde.kwin.Screenshot.screenshotScreen(int screen, bool captureCursor)
method void org.kde.kwin.Screenshot.screenshotWindowUnderCursor()
method void org.kde.kwin.Screenshot.screenshotWindowUnderCursor(int mask)
signal void org.freedesktop.DBus.Properties.PropertiesChanged(QString interface_name, QVariantMap changed_properties, QStringList invalidated_properties)
method QDBusVariant org.freedesktop.DBus.Properties.Get(QString interface_name, QString property_name)
method QVariantMap org.freedesktop.DBus.Properties.GetAll(QString interface_name)
method void org.freedesktop.DBus.Properties.Set(QString interface_name, QString property_name, QDBusVariant value)
method QString org.freedesktop.DBus.Introspectable.Introspect()
method QString org.freedesktop.DBus.Peer.GetMachineId()
method void org.freedesktop.DBus.Peer.Ping()
1 Like

:sweat: My big mouth spoke too soon. The problem occurs again, notice it on firefox when i was trying to “open link in new tab” . It took me 3 right click to get the “open link to new tab” clicked!
This is a minor issue, but when it occurs, it is damn annoying.