Resolution problems

I have a all in one computer , can’t get it write whit the autostart .
This is what i get when i run xrandr , arandr .
exec_always xrandr --output eDP1 --mode 1920x1080 --pos 0x0 --rotate normal --output VGA1 --mode 1920x1080 --right-of eDP1 --rotate normal

nasty when you use i3 and others .
i look all over the internet , but can’t find the write sollution and commands how to solve this and sometimes it broke my system .
So now i ask here , home base

Try this? Just the commands with save and change.

no external monitor . all in one computer , it give my monitor as a laptop one , eDP1 .
Manjaro sells them also , that type of all in one computers .

But why do you try to add a second monitor connected via VGA? That is what the command is doing.

Edit: I guess I do not understand the problem, could you clarify?

My guess it is not loading properly your command from the config. Have you tried this via terminal, does it activate your screen when typing

autorandr --change

If yes you could add it as exec to your config file


this is how the xfce starts up , correct it whit arandr but after boot , the same problems

terminal , autorandr --chance
bash: autorandr: command not found
[bw@arch ~]$

only one monitor eDP1

Replace chance with change :sweat_smile:

[bw@arch ~]$ autorandr --change
bash: autorandr: command not found
[bw@arch ~]$

sudo pacman -S autorandr

To install autorandr.

When I have to correct things like this on i3 I use arandr. Open terminal type arandr adjust settings one is usually setting the monitor to primary the other is setting it to 1:16 instead of 1:8 (might be different not at machine right now.) then save the changes as monitor. Reboot. If it doesn’t stick do it again and when you save overwrite the file that was created the first time. Reboot again (you might be able to just log out). See if it sticks.

i install it already
th first thing i do when i install a new desktop because of the problem , i try it in the config of i3 and other desktops , init xorg and so on , don’t work every sollution i found

i try it all , it must be smething else , can’t find it , reddit arch wiki wikipedia youtube video’s nothing that works , just have to find the write command for it

sorry of my bad typing ! , to fast

Just to clarify:

You have a all in one computer with another external monitor attached via VGA. When you boot you only see the external screen and need to set the screens via display setup to see you all in one computer. When you reboot it is not persistent. Correct?

And just one question, when you boot without the vga cable plugged, can you see your all in one computer screen at all?

I ask because it says command not found. Perhaps just type autorandr first to see whether it is installed.

Somehow I never manage to make it persistent on i3.

However, is worth a try, is perhaps easier.

1 Like
Here you see what computer i use , no external monitors

I think it is because the file needs to be created first then changed and saved again. It’s the only way I have ever gotten it to stick with my monitor. It’s a 27" 1080p AOC and the only monitor i have to do this to. other 1080p monitors work out of the box. :man_shrugging:

1 Like

Thanks a lot , now i have to find out how to do it