Reinstall Grub After Removing Alternate OS & Dual Boot

I’m going to admit to being a complete idiot sometimes. Tonight was no exception.

I decided to try another Linux in dual boot. I didn’t like it, went back into the EOS install thumbdrive and used GParted to wipe the offending OS off the drive.


I buggered up Grub2 on EOS.

So, I went back into the EOS install thumb drive, launched Firefox and googled my brains out for about a half hour. I tried various approaches, but kept getting errors in the terminal. (I’m sorry, I didn’t write them down, but it had to do with writing blocks, and this not being the preferred way, etc., etc, etc.)

I finally found a page that has really good Arch info on how to fix this problem (that I caused), and I thought I’d provide that link just in case anyone else happens to accidentally (or on purpose) have this problem. This page talks about a Linux/Windows dual boot, but it works for Linux/Linux dual boot as well. It fixed mine, anyway.

I think this should be in the Wiki…

No i think you’re being too hard on yourself. This is just what happens. The fact that you are able to figure out what to do to fix it is awesome. So what did you do to mess it up besides wiping out the partition with gparted? Could you not have booted into Endeavour use gparted to wipe out the partition and then update grub with grub-mkconfig -o /boot/grub/grub.cfg ?

Hi @ricklinux…LOL, that would have made a lot more sense! I’ve been used to doing all things GParted from an install disk for so long, that it never occurred to me to fix it from within Endeavour!

Well! That, too, should be in the Wiki! :rofl:

No worries. I think it would work this way. But nothings guaranteed. I’m no different. I install and reinstall so many times you would not believe me if i told you how many times. I’m always trying something new or something different and if it gets messed up then i install it again. That’s the only way you learn. :grin:

1 Like

Totally agree! My wife don’t even have to ask me what I’m doing, she somehow just know when I install new os (and most likely break something down in the process). It’s just: “what are you doing again… It was working yesterday, why would you mess with that laptop again?”. Probably she know that something in that head isn’t correct :grin: How can I explain to non-IT person that I just wanted to see how Wayland performs in Fedora 30 and after few unsuccessful program launches I decided to go back to EOS, but EFI entry was wiped out, so I had to manually rebuild it…? :laughing:


How to explain to your non-IT spouse?
Ah, that’s simple.
You say: Look darling imagine you want to go out and look good. So you try various outfits, hand bags and shoes until you are satisfied with what goes with what.
For us geeks, it’s the same. Wayland, Mir, different distros, you name it.


EndeavourOS wiki already has this covered:


@manuel…Missed it completely! Thanks for pointing it out!!!


My wife’s totally the same. “Do you reinstall again? But it worked? Why?” In the meantime it’s only THAT look and a slightly shaking head. :sweat_smile:
But since EOS I resisted to reinstall and work on my neverending i3wm-project. :roll_eyes:

You are working on i3wm EOS configuration that will be added to net-install?

I thought about it. Right now I’m trying to get a nice working setup for myself. I’m still learning and some dotfiles are not doing what I want. (Yes I’m looking at you, compton!) :face_with_raised_eyebrow::smile:
And I don’t know how simple a EOS-i3 should look like? i3-gaps or not? Mostly same Apps as the XFCE-DE or just terminal-apps?
Maybe we should start another topic about that? This is going very offtopic… :blush:


You are right mister! I3wm for EOS net-install - lets do it together!