Regional/language section missing from System Settings

Hi, I was looking to set my regional/language setting in System Settings, but could not find it there. I have seen threads by other users who do have that section in their systems, but I think it is specific to a desktop environment you use? Because I saw the section visible in e.g. KDE Plasma.

At first I thought this may have been caused by the fact that I use Hyprland with my EndeavourOS installation, but then I checked System Settings via Cinnamon on my laptop, and the section is missing there too.

When I check language settings in Firefox, it says my operating system settings are currently set to “English (United States, posix)”, so it must have been set somewhere.

Am I missing something basic? Do I need to install a package to have access to those settings?

When you say system settings are you specifically referring to KDE plasma’s system settings or something else?

Thank you for the reply. I currently do not have KDE Plasma installed, so I’m referring to non-compositor System Settings that open when I search for that in a launcher in Hyprland. Its UI looks like this:

It should be from Cinnamon I think? Because I still have Cinnamon installed alongside Hyprland, and the UI looks similar (identical?) to the Cinnamon System Settings from my laptop.

Yeah, that looks like the Cinnamon System Settings.

Keep in mind that each DE has it’s own separate application so they won’t all have the same functionality.

As far as I know, the Cinnamon version requires this to be set outside of the settings application.

There is a package in AUR called mintlocale but there seem to be some known issues with it.

Thank you, I will look it up.

The Arch wiki for Cinnamon links to this page with manual method for configuring locales.

Oh that looks helpful, I didn’t think of looking it up there, I thought the setting would be available as GUI if everything was working correctly. Thank you, I’m going to look into that now.