"Region & Language" settings option throws an error and doesn't apply changes

I’m trying to adjust Time/Date settings to display months and days in English but KDE throws an error which makes no sense to me since I do have glibc package.

pacman -Q glibc
glibc 2.36-7

Changes also are not applied after reboot.

Wiki suggests to remove ~/.config/plasma-localerc but I’m not comfortable to delete stuff if I don’t have full understanding of how things are interconnected and function.

Is it safe to indeed remove such file or there might be another solution?

Yes. You can just rename the file (add an extension) so you can compare it with the new one that will be created after re-login.

On the topic, Plasma changes stuff, but does not have any mechanism to merge previous configurations to the new ones :person_shrugging: .

1 Like

Thank you. Basically the newly generated file is the same as the old one.

Recreating it did the trick only partially: it updated date and time language for lock screen and clock/calendar in tray but not for login screen :confused:

I thought we were after the error message in GUI. Was it gone?

These are session connected, so it works as designed.

This is system connected, so it works as designed. :wink:

If you want to change SDDM (login screen) locale, change system locale relevant settings. Check Archwiki on howto.

1 Like

No. It still pops up whenever I apply some changes.

Probably I poorly worded that. I meant not keyboard layout but date and time such screen displays, like:

Thursday, 19 January 2023

Layout for both login and lock screens is basically the same. Lock screen however shows such date in English (as shown above) but login screen - no.

This is a multi-user system issue.
If you only have one user, or more, may have a different approach.
User setting for display language should be independent of system display language.

Display language is controlled from the LANG environment variable.
For system, this is set at /etc/locale.conf
For user, it depends on the DE, and/or session type.

TBO, I haven’t understood what exactly are your display language preferences. :person_shrugging:

Ok, I’ll try to explain it better :slight_smile:

I’m the only user of this machine. During installation process I chose English as my language and Poland as my current location. Afterwards while customizing and tuning my system I noticed that only lock screen, login screen and clock/calendar in tray have days and months written in Polish. Everything else is displayed in English.

My end-goal is to set English language to be system wide with the exception of location/timezone as Poland and measurements as metric. So as I wrote in first post I tried to adjust individual region/language settings in order to achieve that but encountered mentioned problems.

Thus seemingly trivial task turned out to be more complex :slight_smile:

And looking at my /etc/locale.conf, I see that my settings definitely got messed up…


Leave only the LANG setting in that file and delete the rest.
Everything should be set to English.

Are you confusing display language with timezone? They are independent.
What characters do you want to be displayed in Poland?

I am still confused, or I have to finish with my 2nd cup of coffee :slightly_frowning_face:

1 Like

No, I believe I’m not.

English (en_US , UTF-8)

We have a communication problem :rofl:
Please, try a little more. :pray:

I rephrase:
Show me something that is printed on the screen in English language, and write that one in Poland (like how you expect to be printed on the screen).

Can’t argue with that :slight_smile:
In any case, I really appreciate you sticking around and your willingness to help.

Basically I achieved what I wanted by editing /etc/locale.conf as you suggested but if you don’t mind, I’d like to ask you to clarify few additional things.

In my understanding ~/.config/plasma-localerc, which reflects settings set in Plasma’s GUI (first post screenshot), overwrites/updates /etc/locale.conf. And to see such end-result we can execute this in terminal:



If so, my question is: what might be the cause of some settings from ~/.config/plasma-localerc not being applied to /etc/locale.conf ?

Here is my ~/.config/plasma-localerc


Here is /etc/locale.conf


And here is locale output in terminal


As you can see, changed LC_TIME and LC_MEASUREMENT from Plasma’s config got applied but LC_TELEPHONE stayed the same.

The only conclusion I was able to make is that it’s some kind of bug but maybe I’m missing something :confused:

1 Like

If using sddm it seems to be an issue of it not respecting locale

If the file is not edited by you with an editor, but is just updated after changing Plasma relevant System Settings, then only a Plasma dev can answer about the difference.

From what I know, locale output shows assumed values (quoted) for the variables that are not explicitly set somewhere (system, user session).
If some setting is important for you and not set properly, try a standard method to set it:
Export the value from a dot file like .profile or .xprofile. For example,

export LC_TELEPHONE="en_GB.UTF-8"
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.