Reflector Simple issues....?

I’m on EOS Plasma just updated to the new reflector-simple actually, i launch it select United States & Canada https then click ok and I get this

reflector-simple is working, please wait …

it went on for well over a minute, then i closed it out and boom the list pops up asking for my password. Until recently it used to take literally seconds to get a updated server list. I see using our forums/google some are having issues, wanted to start my own thread as not to hijack someone else’s. Thanks!

1 Like


1 Like

I’m just leaving it run to see what happens … nothing. :rofl:

Edit: Closed the terminal window and nothing came up.

Edit: Sorry, Actually it did but it’s in the window in the taskbar?

1 Like

If I remember correctly, @manuel said that the dev for reflector changed how he is doing things and reflector (which reflector simple relies on) now takes between 2 to 3 minutes to run.



Ok thanks

Now that you mention it … :man_facepalming:t5:
Thanks for the reminder!

1 Like

It works if you close the terminal window but i left it run and it’s not opening the save window with results. Just keeps running.



Yea mine does the exact same thing.

If you run update mirrors from the welcome app it’s almost instantaneous. :thinking:

Edit: I think @manuel will have to check this as it may some issue with the software?

Sorry it took so long, I had to fire up one of my x86_64 computers to check on things as reflector/reflector simple do not exist in ARM.

From the Welcome screen, I initiated Update Mirrors, entered US & https, left the welcome screen up and went and checked E-mail. After a period of time, it came back with a terminal window with a list and offering to save to the mirrorlist. It worked as expected, just took a lot longer. Remember, the welcome screen is the parent window, the results come back in a window created by a child process.

I also started reflector-simple outside of welcome from a terminal as user
$ reflector-simple
and it completed as expected.

I am not sure if reflector-simple was intended to run outside of welcome or not as there isn’t a man page for it. As per @ricklinux manuel will have to answer that.


I ran it through the welcome app & its the same as running reflector-simple.

I wonder if we don’t have it configured? Because mine ran forever and did nothing!
Edit: Do you have to configure this?

I don’t recall ever having to configure reflector-simple.


I just tried it again and now when you click on reflector-simple it automatically brings up the list. There is no terminal opening and spinning icon. :thinking: This is strange.

Edit: So now it’s working.

It works fine for me, but I haven’t updated this machine for a few days. Let me update and see if it still works.

reflector 2020.12-1 -> 2020.12.7.1-1
reflector-simple 1.8-1 -> 1.9-1
are part of the update. Let’s see what happens after I complete the update.


1 Like

Look here! :grin:

[ricklinux@eos-kde ~]$ sudo pacman -Syu
[sudo] password for ricklinux: 
:: Synchronizing package databases...
 core is up to date
 extra                    1643.4 KiB  14.2 MiB/s 00:00 [----------------------------] 100%
 community                   5.2 MiB  31.8 MiB/s 00:00 [----------------------------] 100%
 multilib is up to date
 endeavouros                14.7 KiB   133 KiB/s 00:00 [----------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (2) boost-libs-1.74.0-2  reflector-simple-1.9-1

Total Download Size:   2.38 MiB
Total Installed Size:  9.57 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 

Edit: Just updated it and now it’s doing it again. Terminal is open running with spinning icon.

1 Like

Edit: Interesting, i already have these installed and it still taking forever… :thinking:

When it works properly the terminal window shouldn’t open in my opinion. I had it working then updated and it didn’t work. I closed the terminal window and tried it again a few times and now it seems to be working. Comes up fast with the list and you select and then it runs and opens the password box.

Edit: Spoke too soon. :no_good_man:

1 Like

I just finished the update, and it still works for me both from welcome and outside of welcome. If anything, it is faster than it was prior to update.


Don’t know what to say but I know @Christopher67 is on KDE and so am i?

1 Like