Reboot doesn't work?

when i reboot text on my screen is show saying
“watchdog: watchdog0: watchdog did not stop!”
then after a few minutes it says it again how do i fix this?

shutdown then power on works perfectly but reboot gives me this error and i have to force shutdown?
how do i fix this?

We need more infos on your system. First of all, on top of this webpage, Help>forum log tool. There is info how to provide logs of what you system is doing and basic info like which DE etc you are using…

Did this start happening since you installed eos, or after an update, are you forcing shut down regularly (not a good idea)? How long did you wait for shutdown?

Please refer to:’’

PS. ArchWiki is your friend. Well, most of the time… :wink:

1 Like

Try this and see if the messages stop:


im using kde and here are the Systemd Journal from the page
using “journalctl -b -0 > /tmp/journal”

i may have forgotten to say it boots up in 7secish and shutdown in 4 and even after leaving it for 10min it still was stuck on that text screen without rebooting.

it works but the errors still show up but it reboots in seconds now thanks

1 Like

I have the same error, same message on shutdown. Got it fixed with blocking using the method Elloquin linked (Watchdog didn't stop at shutdown - #40 by Elloquin). The only question is, why can’t this legacy watchdog just be left out? I was running Manjaro on my main machine until recently and my second machine (my girlfriend’s machine) is still running Manjaro KDE. There is no talk of watchdog more (was earlier there also once the case). If it really should be part of the kernel, they have it at least well removed.

There is a small thread about it here and where it comes from and why:

sp5100-tco: Watchdog hardware is disabled / Kernel & Hardware / Arch Linux Forums


OK, now I’m a step ahead there. I now know now that it is my motherboard because it is not IPMI compliant.

I have again looked into my /etc/modprobe.d file. I had solved this differently, but I don’t remember where I got it from:

Blacklist the modules in /etc/modeprobe.d/blacklist.conf (create this file if you don’t have it).

To disable watchdog timers (both software and hardware), append nowatchdog to your boot parameters.

sudo nano /etc/modprobe.d/blacklist.conf

# disable intel mei (including mei_watchdog)
blacklist intel_pmc_bxt 16384 1 iTCO_wdt
blacklist iTCO_vendor_support 16384 1 iTCO_wdt

# Do not load the 'iTCO_wdt' watchdog module on boot.
blacklist iTCO_wdt

=> which version is better?

I’m getting this message on shutdown/reboot ect, IF i choose to ignore it does it really matter? Does it slow the shutdown/reboot time at all? Thanks!

Edit: Ok i did this and it did not work. Looking to try something else.

You will still get the message. That fix just helps if it is delaying reboot times or stalling them. It will also clean up any journalclt errors you might be getting because of it. The reboot message is harmless otherwise.

1 Like

I do seem to be rebooting a hair faster though lol.

See here.

Hardware watchdog driver for the AMD/ATI SP5100 chipset.

sp5100_tco is an AMD specific watchdog module. I very much doubt that this advice will be helpful to anyone with an Intel processor.

If you want to blacklist watchdog modules, you really need to determine what modules are in use on the system. Just blindly blacklisting random modules until something works is not a very efficient way to go about things.

You could try running something like this:

lsmod | grep -e dog -e wdt -e tco

This will look for the most common watchdog modules that are used for Intel or AMD processors/mobos. Once you see what module(s) are in use on your system, then you can blacklist them.

1 Like

Try adding nowatchdog to kernel boot parameters (if you haven’t already) and see if that will get rid of the message as well.

1 Like

Dang, I’m running 10th Gen Intel. That Explains it lol.

[christopher@christopher-EndeavourOS ~]$ lsmod | grep -e dog -e wdt -e tco
iTCO_wdt               16384  0
intel_pmc_bxt          16384  1 iTCO_wdt
iTCO_vendor_support    16384  1 iTCO_wdt
[christopher@christopher-EndeavourOS ~]$ 

1 Like

So i can add this to my sudo nano /etc/modprobe.d/sp5100_tco.conf

blacklist iTCO_wdt
blacklist intel_pmc_bxt
blacklist iTCO_vendor_support

Like this?


I didn’t add it yet, no.


1 Like

Try blacklisting the modules first. If that alone doesn’t help, which it should, try the boot parameter as well.