Reached Graphical User Interface

So, my bluetooth keyboard was not pairing up correctly, so I spammed the bluetooth toggle a lot. It didn’t work, so I restarted thinking, it’ll work. But, I’m stuck on loop where it prompts me to enter password for my user, and when I enter it, it shows up this screen again.
I’ve seen this issue for others with nvidia gpu, but my machine has an intel cpu without integrated gpu.
I can access the terminal with tty, but I cannot access commands in any random path. I need to point to the location of binary, /bin/ls or /usr/bin/ls to use the commands.
I’ve tried updating my system being on /usr/bin directory, and it works as expected.
Things I’ve tried is, systemctl stop/disable bluetooth, that’s pretty much it. Can I get some help or steps in the right direction please?

Also not sure if it’s relevant this is my output on systemctl status bluetooth. There are some error here.

So, I added the following line to /etc/bluetooth/main.conf and I could log in.


This issue is repeated when I restart. What exactly is happening here?

This is most likely because the PATH variable was not fully initialized during that boot.

Can you clarify what you mean by this? What exactly did you do before the issue occurred?

I tried to connect my keyboard to bluetooth, but the toggle icon, would not be on. It’d stay at off only. So, I just kept on pressing it.
It turned on, but would go back off immediately. So, I repeated this for quite sometime.

Are you currently able to boot into system normally? You mentioned something about not being able to boot into a graphical interface. Did this occur after you enabled bluetooth.service?

I could boot into the system. But then again when I tried to restart, it’s stuck on the same loop. I tried accessing the tty, disabling the bluetooth service and restarting and it’s not working again, as in can’t boot to my GUI

Check the journal entries. When you say “stuck on the same loop”, I’m assuming you mean you’re stuck at the greeter where you type your password (when you hit enter after typing in your password, it brings you back to the greeter instead of into your GUI). When you get “stuck”, switch to a tty and run journaclctl -b 0.

The orange line is asking to remove executable permission bits for firewall applet. It also logs, proceeding anyway at the end, so I’m assjming this isn’t significant.

Instead of using a screenshot, can you post the entire output using the eos-logtool or using something like pastebin?

1 Like

I’m sorry, I clicked a pic using my phone camera for this. Can I upload directly to pastebin from that cli?

Please check if you are using lightdm. Another user mentioned that the latest version of lightdm causes a login loop.

If lightdm is the culprit, then the bluetooth and infinite login loops are two unrelated issues.

Just use the eos-sendlog tool. Pipe the output of journalctl into the command, like so:

$ journalctl -b 1 | eos-sendlog


The -b flag in journalctl allows you to specify the problematic boot. So if your previous boot is problematic, use -b 1. If the boot before that is problematic, use -b 2 etc.

Thank you for this, I installed sddm, gdm and I can now log in, into gnome. I was using the i3 version of endeavour os, and when I try to log into i3, I go back to the greeter screen. Does this mean, this is i3 specific issue now?

Not at all. I’m using i3 on Arch but without a display manager. It’s your previous display manager (lightm) that’s preventing you from logging in. You can use i3 without a display manager as well like I’m currently doing.

First of all, I’m extremely thankful for helping me out all this while.

Also, new development.
I added exec i3 in
and when I click startx, I can login to i3, and it works as expected.

But for this, I need to go to tty, login to my user, and enter startx, I cannot login with sddm though.

What do you recommend here for me, should I get rid of the login manager?

Do not edit /etc/X11/xinit/xinitrc directly. Instead, create a .xinitrc in your home directory. You can start by copying the default configs into .xinitrc like so:

$ cat /etc/X11/xinit/xinitrc > ~/.xinitrc

After that, edit the .xinitrc file and add exec i3

It depends on your preference. Personally, I don’t bother with a display manager. For me, a display manager doesn’t do anything useful except making your login interface look pretty. If you want something completely minimal, the xinit system is more than enough to start your graphical session. If you want something a little bit more fancy, you can choose a display manager. The latest version of lightdm has a bug as report by another user (see my post above), but there are other options to choose from (sddm, etc.). If you still want to use lightdm, you need to downgrade lightdm to an older version until the bug gets fixed.

Okay, got it. Thank you very much.
Think I’ll go your route as well, remove the display manager entirely.

Will the display manager interfere if I have exec i3 on .xinitrc file? Should I disable the display managers?

Yes. You need to disable them with systemctl.

Got it, thank you very much!