Question about pacman - arch and nvidia

Hello, I asked a few days ago here about issues with nvidia drivers (update to 495.46) here!

However, my issue was not resolved (I repaired optimus-manager due to its python issue, then my GPU was noticed again by the system, but games were not starting (steam).

those games were working fine with 495.44 and I restored with timeshift, but I dug anyway deeper, had a few boot issues etc. but came to some findings:

That I can use linux-lts with nvidia-lts driver to have a more stable system.

according to the nvidia-wiki - which leads me to the official nvidia page, where I can select my GPU to see a suitable driver (I took the production branch since I want LTS) - I see that my drive should be 470.94.

now I found that downgrading is possible. Therefore I tried to start with the nvidia driver, which, to my knowledge, consist of nvidia-utils, nvidia-dkms & nvidia(-lts).

however I was not able to downgrade:

error: failed to prepare transaction (could not satisfy dependencies)

In addition the downgradeable list was only showing me

470.74 &

Therefore I have a few questions:
1.) how do I update my system without updating my drivers?
1.1) is it possible to update the kernel in the future but not the driver?
2.) how can I downgrade the nvidia drivers?
3.) does someone have experience with a GTX 1050Ti (notebook) and the open source driver, + is this a possibility for me?

thanks in advance.

You shouldn’t. Arch is rolling release distro. The packages are made to work together. Holding packages back, especially nvidia drivers requires substantial knowledge to hold a series of packages back without breaking your system.

Those drivers are tied to the kernel versions. You can’t hold them back unless you also hold the kernels back. You could instead switch the dkms drivers which work with multiple kernels but that is whole different rabbit hole :smile:

Assuming your card really does require the 470 series, you shouldn’t downgrade. You should install the 470 series drivers which is a different package.

The 1050ti shouldn’t need the 470 drivers. Are you positive that is a requirement?


This is the problem that should be investigated - Steam games are working for many other people (myself included).

Hmm… reading the other thread (again) it looks like certain games have stopped working with 495xx - did that start with a certain version or did it happen with all 495xx releases?

If you do want to switch to the 470xx series then switching to the drivers in the AUR (or my kernel-lts repo) is a better option than downgrading and leaving your system in a partially-upgraded state for the foreseeable future.

1 Like

Ok thanks for the heads up. wont do this then. :smiley:

ah. I just want to be able to debug my problem to learn the handling with nvidia proprietary drivers. :smiley:
or in worst case go into the nouveau direction.

I may dont understand this. - 495.xx are driver release numbers right?

from the 495 release readme my card looks supported.
However when I search via their driver model selection I thought that maybe my card i better supported in the 470 one since this would be production branch (I assume more stability with him)

However I may have a false picture what package versions and bleeding-edge means, TBH. :smiley:

sorry for stealing your time, I really appreciate your help, though.

So. should I file a bug report for those drivers now ? 495?

PS: I am currently on an out-of-date system due to my snapshot restore. however I think things will get worse the longer I am not updating.

it started with 495.46.
495.44 is doing fine (which I currently use)

I had with 495.44 issues with dying-light, but those were bypassed by switching to proton instead of native running.

but with 495.46 no game wont start. (it has something (I think) to do with the “noticing” of the GPU, since KCD shows me the missing D3D error) therefore I thought that it was about the python update issue with optimus-manager.

but rebuilding optimus-manager worked fine however I was unable to boot then into NVIDIA mode, so it may not have worked out.

do you linux magicians know some logs where I can identify the issue?

So is Optimus Manager working? How are you booting your system now, and how are you trying to use the NVIDIA GPU? Is the NVIDIA driver loaded?