NVIDIA driver issue - KCD (steam) does not find GPU

Helly guys,

I have read already some threads about issues when updating the system with yay.
However, after the update I was able to reboot. Unfortunately the only things which are not working are my steam games (I do have no others /standalone games installed).

The issue is that it seems that my steam games are not able to find the GPU.

1st issue: Dying light which was running native very fine is not able to be shown. The game starts but when the menu should be loaded a quarter screen is flickering, 3-quarter are black.
2nd issue: Kingdom come deliverance (via Proton) fails to start and throws error: “Unsupported graphics card detected”. By searching for the issue (there isnt much found) I saw the same KCD error on steamcommunity
the mentioned KCD.log shows not much only that no supported GPU was found.

I have done now a rollback with timeshift and didnt update yet, however this is only a temporal solution and I kindly ask more sophisticated persons to maybe provide an answer whats going on with this driver update.

PS: I already thought that python upgrade was the guilty as mentioned here!, but unfortunately optimus-manager rebuild did nothing for help.

Best Regards,
Ravebous Twinky

I dont’t have any Idea about this problem, but I have you tried nouveau?
I find it alot easier to deal with and it’s probably better supported by the linux community.

Sometimes the linuxexperience is hardware dependant:
On my laptop Manjaro is fine, but on my desktop it`s horrible, so maybe you could try manjaro :man_shrugging:

dos optimus manager start nvidia when using steam ?

The Steam thread you referenced is not only 4 years ago, but it’s about the Windows version. I suspect that the problem could be related to the latest Nvidia driver; what version are you running?

so maybe you could try manjaro

no thats no option for me. :wink:
1st I love EOS for giving me this learning curve.
2nd I read already so much about downsides when it comes to Manjaro that I either switch back to Pop and demolish it until I have my light i3wm setup ready or I keep diving into arch. :stuck_out_tongue:

but I have you tried nouveau?

yes I did it as a fast measure. However I booted into black screen and rolled-back with timeshift again.

I never tried the open source driver. is it better for playing?
Since I came from pop and proprietary drivers were working there I thought to keep it with them.

Yes I know sorry for that.

I thought since KCD runs via proton that the error (DirectX error) has something to do with maybe proton-vulkan emulation (I dont know anything about those in detail, so bare with my ignorance)

still on 495.44-6.
but the error happens when I update the system to 495.46-1

Optimus manager is running on the right GPU.

However I havent checked if steam is using it.
How can I find out?

I was under the misconception that KCD was available for both Windows and Linux (native); sorry about that. As far as Proton is concerned, the latest 6.3 version should be able to handle this game and its DirectX requirements. I just got done installing Diablo 2: Resurrected via Steam - actually installed Battle.net, then installed D2R from there - and it runs great.

The devs of KCD had many bugs already in the windows version. I dont want to think what had happened on a linux native one if they had to bugfix 2 systems. :smiley:

But yeah. KCD+Proton runs perfectly fine with OLD nvidia driver.
However the new one borks my game experience. (maybe it has also to do with python dependencies but optimus-manager seems fine to me)

If you want to be sure, you can add this custom launch option in steam for the game:

1 Like

Did you rebuild that in your rolled-back system, or within the fully-updated system?

(Or, better, within a chroot using e.g. mkchrootpkg?)

Well have you tried manjaro? I also read alot about arch downsides, so I went to manjaro.
I’m on endevourOS now…

No in the upgrade system (on the rolled back one there was no need to do that)

chroot is a good advice. will look into that


yes. tried manjaro and it was a hell of a ride (pun intendet)
it was real buggy for me, havent looked into it in detail since my first experience was a mess.

I am quite happy with Endeavour os and especially my learning curve with it.
I am really curious about how to fix my issues with arch since they should be able to be fixed.
worst case I have to roll back my system. so that is not a downside to EOS or arch