Pulseaudio Microphone Slider Moving

In pulse audio, when I go to input devices my microphone slider keeps moving by itself. I set it to 52, but sometimes it moves all the way to 100, 65, 77 or other various number above that level. I do not have that issue with my headphones in output device. I tried saving the pulse audio config as well as the alsa config and yet my microphone volume(gain) still increases.

Just a word of warning, I had this issue with pulseaudio randomly ramping up output to 100 without any user intervention some years ago - only with audio output. After losing some hearing due to acoustic shock when this happened while wearing headphones, I learned my lesson. If you’re using headphones, be aware.

Can you try checking if there isn’t an auto-gain setting somewhere in your mic settings. It might be trying to adjust to your environment. Beyond this, I don’t have much of a solution as I’ve switched to pipewire.


This might be the solution… I would describe the current state of Pipewire as “better than Pulse, but still far from perfect”.

1 Like

That sounds really painful, thankfully my output volume has stayed the same for years and it is only the input.

How was it switching to PipeWire? Any downsides compared to Pulse and was the move a hassle?

It took two minutes to remove Pulseaudio and install Pipewire. No downsides for me, - it’s mostly audio output I use it for.



1 Like

I installed pipewire and removed pulseaudio and it did not fix it. The volume of my microphone raised by itself by 14%.

Maybe set the following in /etc/pulse/default.pa


load-module module-echo-cancel

Then reset pulse audio with pulseaudio -k

I got no solutions - but I also face similar issue on my laptop. Interestingly enough - I face it when Chrome is using my mic.


See if there is a pattern. If this volume increases only while using specific apps. Then you may be able to find fix for those app. Like for chrome, I installed an extension, which has been working find for the past week.

I’ve been using pipewire for the past month and I noticed a few things. The mic default resets every time I boot up and the microphone volume changes with vivaldi. I assume installing the extension will fix it. I also had this issue with teams, but I have not used teams in 3 months now.

Pipewire, needs more time in the oven. It also doesn’t play nicely with Firefox videos/audio, and a few other audio apps. I had to revert back to using Pulse Audio.

Edit to add, this podcast covers the WONDERS of Pipewire. They at least acknowledge that many users complain about it not working with Firefox and other apps. Unfortunately, they kind of dismiss it and say it is because the distros don’t have the latest apps. I find that hard to believe with Arch. Kind of strange.

Can’t say about Vivaldi. On Google Chrome, the plugin has been working fine for me. So its worth a try.

For MS Teams, if you join as guest from browser, I don’t think there is a way to fix it. But if you have signed in to the desktop app, you can go in settings and disable auto mic adjustment.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.