Pulseaudio - Bluetooth - Razer Leviathan

Hello endeavourers,

I’m having some trouble connecting my Razer Leviathan bluetooth soundbar. It connects well with Bluetooth, but after that it won’t switch to A2DP_Sink.

I have already tried the following topic steps: Bluetooth - pulseaudio-bluetooth not pulled

pacmd list-devices output:

   index: 2
	name: <bluez_card.7C_96_D2_16_39_E6>
	driver: <compiler_depend.ts>
	owner module: 26
		device.description = "Razer Leviathan"
		device.string = "7C:96:D2:16:39:E6"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "speaker"
		bluez.path = "/org/bluez/hci0/dev_7C_96_D2_16_39_E6"
		bluez.class = "0x240414"
		bluez.alias = "Razer Leviathan"
		device.icon_name = "audio-speakers-bluetooth"
		a2dp_sink_sbc: High Fidelity Playback (A2DP Sink: SBC) (priority 40, available: unknown)
		a2dp_sink_aac: High Fidelity Playback (A2DP Sink: AAC) (priority 40, available: unknown)
		a2dp_sink_aptx: High Fidelity Playback (A2DP Sink: aptX) (priority 40, available: unknown)
		a2dp_sink_aptx_hd: High Fidelity Playback (A2DP Sink: aptX HD) (priority 40, available: no)
		a2dp_sink_ldac: High Fidelity Playback (A2DP Sink: LDAC) (priority 40, available: no)
		off: Off (priority 0, available: yes)
	active profile: <off>
		speaker-output: Speaker (priority 0, latency offset 0 usec, available: unknown)
		speaker-input: Bluetooth Input (priority 0, latency offset 0 usec, available: no)

when trying to switch I simply get the error "Failed to change profile to a2dp_sink.

[evad@GLaDOS pulse]$ pacmd set-card-profile bluez_card.7C_96_D2_16_39_E6 a2dp_sink_sbc
Failed to set card profile to 'a2dp_sink_sbc'.

Any profile I try fails. Setting profile to “off” means I cannot use it as sound output ofcourse :).

I have Sony WH1000XM3 headphones, and they connect just fine, switch directly to the correct a2dp profile, so I’m kind of starting to think this is some incompatibility with Linux and the soundbar maybe?

Do you have pulseaudio-bluetooth installed.

Yes, sorry if that wasnt clear, the link I added showed that.

Have you tried pacmd ls and manually set a profile.


Yep thats the command I shown in my opening post, except using the index number I used the name, which is similar command. Also similar error output.

Found some more info:

When looking at the journalctl of bluetooth service I get this error thrown at me when the device connects:

bluetoothd[1061]: profiles/audio/avdtp.c:avdtp_parse_rej() START request rejected: Bad State (49)

Have you tried bluetoothctl

You may want to use bluetoothctl and have a look. Then use the tools to untrust,remove,pair if it doesn’t pair then scanon, then scanoff, then pair if it pairs then connect.

Sometimes just redoing the pairing and connecting gets it going correctly.

1 Like

For some reason, it now worked, have done that before. I don´t know anymore. Thanks alot!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.