Proton not working on ext4 partition

Hi everyone,

I’m trying to play BG3 on an external ext4 drive (the game is too heavy for my main drive). This needs Proton. I made an ext4 partition for this, as I had problem with the nfts3 partition my external disk previously had.

However Proton seems to instantly crash when launching the game (hit the green play button → launching for 1 second → Button going back to green).

The Steam log from PROTON_LOG=1 %command% is too long for me to post here, is there a workaround that ?

I hope someone can help me. :pray:

Thanks a lot gentlemen !

BG3 on an external ext4 drive works for me, so I doubt that it is a general problem.

Additional info would be how you mount said drive and SMART info of that drive. If you can, provide some information about your system as well.

1 Like

Thank you very much !

With which command could I provide the relevant info about the mount and the drive ?

It might come from that since I’m quite new at playing with partitions and related stuff and I tried editing some things in fstab. For example

# /dev/sda2 LABEL=endeavouros
UUID=d2c35011-896a-4f37-9492-1561e2286f40       /               ext4            rw,relatime     0 1

# /dev/sda1
UUID=D25A-2416          /efi            vfat            rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro   0 2
UUID=123-b030021d-d9fe-4844-997c-06977861fc80 /home/bg/jeux ext4 defaults,nofail 0 0 mount the filesystem
/dev/disk/by-id/usb-Seagate_Expansion_NAAELA3H-0:0-part1 /mnt/usb-Seagate_Expansion_NAAELA3H-0:0-part1 auto nosuid,nodev,nofail,x-gvfs-show,noauto 0 0
/dev/disk/by-uuid/b030021d-d9fe-4844-997c-06977861fc80 /mnt/b030021d-d9fe-4844-997c-06977861fc80 auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Disquette 0 0

3259.230:0114:0118:err:eventlog:ReportEventW L"Description: A .NET application failed.\nApplication: LariLauncher.exe\nPath: Z:\\mnt\\b030021d-d9fe-4844-997c-06977861fc80\\SteamLibrary\\steamapps\\common\\Baldurs Gate 3\\Launcher\\LariLauncher.exe\nMessage: You must install .NET to run this application.\n\nApp: Z:\\mnt\\b030021d-d9fe-"...

I assume the path for BG3 is correct and exists? Did Steam install .NET?

Have you tried verifying the BG3 installation through steam?

Since you seem to simply be missing the .NET application, I guess we can skip OS/ hardware debugging for now, at least as long your Steam Library actually exists on that drive/partition

1 Like

Well the NET part is weird, I try looking at this and I had a slightly out of date AUR package for it. So I try installing the newer one. But This log should be after re-installation.

As for the path

I guess this should work ?

And I’m going to re-check the game files.

So your drive should be mounted correctly(-ish).

You got .NET from the AUR? I thought Steam installs it on demand per game? Maybe try removing that AUR package and let Steam handle that?

1 Like

Yeah, I don’t why it was an AUR package in the first place. Is there a way to make steam check its own files ? To force it to install .NET on its own terms ?

I don’t know if there is a way to ‘force’ steam to install it’s own. What I would try is to

  1. Remove the AUR package
  2. Verify the BG3 installation through Steam
  3. If it still fails completely remove the BG3 installation (manually remove the directory, maybe even the library on your external drive; Create a new Library on that drive) and reinstall it. When starting, Steam should automatically install the needed .Net library. (You use Proton Experimental for BG3, right?)
  4. If it still gives you that error try, if at all possible, to install it temporarily on you main drive. If it works there then it’s some weird PATH issue…
1 Like

did you try protontricks? you can install libraries in the game’s prefix with it, just make sure you install the right version. It needs a windows install of .net, linux version from the AUR won’t work. Steam should have installed it for you, did you move the game to the external drive manually or from steam?

1 Like

Thank you again for your time and insights. :pray:

Well I tried everything except step 4 (because my main drive isn’t big enough to test it).

I think Steam isn’t installing dotnet as the log shows the same message aboutt how I need to install it.

I’ve deleted all files and made a new library with Steam. I noticed my disk wasn’t part of the storage although I had added it previously (maybe something wrong there ?)

I do use Proton experimental, tes. :confused:

This what Steam says is happening when I launch it, from the terminal.

fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
ioctl (GFEATURE): Broken pipe
ioctl (GFEATURE): Broken pipe
ioctl (GFEATURE): Broken pipe
ioctl (GFEATURE): Invalid argument
ioctl (GFEATURE): Invalid argument
ioctl (GFEATURE): Invalid argument
ioctl (GFEATURE): Broken pipe
ioctl (GFEATURE): Broken pipe
ioctl (GFEATURE): Broken pipe
/bin/sh\0-c\0PROTON_LOG=1 /home/pcb-heavy/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=1086940 -- /home/pcb-heavy/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/home/pcb-heavy/.local/share/Steam/steamapps/common/SteamLinuxRuntime_sniper'/_v2-entry-point --verb=waitforexitandrun -- '/home/pcb-heavy/.local/share/Steam/steamapps/common/Proton - Experimental'/proton waitforexitandrun  '/mnt/b030021d-d9fe-4844-997c-06977861fc80/SteamLibrary/steamapps/common/Baldurs Gate 3/Launcher/LariLauncher.exe'\0
chdir "/mnt/b030021d-d9fe-4844-997c-06977861fc80/SteamLibrary/steamapps/common/Baldurs Gate 3/bin"
ERROR: object '/home/pcb-heavy/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/pcb-heavy/.local/share/Steam/ubuntu12_64/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: object '/home/pcb-heavy/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/pcb-heavy/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/pcb-heavy/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Game 1086940 created interface STEAMAPPLIST_INTERFACE_VERSION001 / AppList
Game 1086940 created interface STEAMAPPS_INTERFACE_VERSION008 / Apps
Game 1086940 created interface STEAMHTMLSURFACE_INTERFACE_VERSION_004 / HTMLSurface
Game 1086940 created interface STEAMHTTP_INTERFACE_VERSION002 / HTTP
Game 1086940 created interface STEAMINVENTORY_INTERFACE_V002 / Inventory
Game 1086940 created interface STEAMMUSICREMOTE_INTERFACE_VERSION001 / MusicRemote
Game 1086940 created interface STEAMMUSIC_INTERFACE_VERSION001 / Music
Game 1086940 created interface STEAMPARENTALSETTINGS_INTERFACE_VERSION001 / ParentalSettings
Game 1086940 created interface STEAMREMOTESTORAGE_INTERFACE_VERSION014 / RemoteStorage
Game 1086940 created interface STEAMSCREENSHOTS_INTERFACE_VERSION003 / Screenshots
Game 1086940 created interface STEAMUGC_INTERFACE_VERSION010 / UGC
Game 1086940 created interface STEAMUSERSTATS_INTERFACE_VERSION011 / UserStats
Game 1086940 created interface STEAMVIDEO_INTERFACE_V002 / Video
Game 1086940 created interface SteamController006 / Controller
Game 1086940 created interface SteamFriends015 / Friends
Game 1086940 created interface SteamMatchMaking009 / Matchmaking
Game 1086940 created interface SteamMatchMakingServers002 / MatchmakingServers
Game 1086940 created interface SteamNetworking005 / Networking
Game 1086940 created interface SteamUser019 / User
Game 1086940 created interface SteamUtils009 / Utils
Game 1086940 method call count for IClientAppManager::GetCurrentLanguage : 1
Game 1086940 method call count for IClientAppManager::GetAvailableLanguages : 1
Game 1086940 method call count for IClientAppManager::GetAppInstallState : 2
Game 1086940 method call count for IClientUtils::RecordSteamInterfaceCreation : 22
Game 1086940 method call count for IClientUtils::GetSteamUILanguage : 1
Game 1086940 method call count for IClientUtils::GetAppID : 24
Game 1086940 method call count for IClientUser::GetSteamID : 1
Uploaded AppInterfaceStats to Steam

I’m unsure how to proceed at this point. Could I try installing Steam on my secondary drive so that everything is there ? IDK if it even makes sense.

Thank you again !

Thank you for your answer !

I never quite get how to use protontricks, maybe I should give it a go.

The game files were downloaded once. It was on a drive I since formated (to ext4). I simply moved the files back and checked the files to be sure nothing was missing. In between, the files were simply on another, external, drive. (Given my poor internet connexion this seemed like the best idea given the 130go of the game).

Also it does seem Steam is not installing .net. After deleting the AUR package, I’ve still got the same message telling me to download it. :confused:

I’m not really sure what to do at this point. Since I’m not sure after your other answer: Did you do a clean re-download of BG3 or did you just copy paste files? I’m not sure exactly how Steam on Linux handles all that containerization in the background, so I wouldn’t be surprised if copy pasting messed up things (i.e. some links point to no longer existing locations). There is probably no way around downloading 130gb again.

But if you already did try that, you could try installing it (from scratch) on another drive. I.e. click uninstall in the steam interface and then install again. When prompted by steam, create a new library on the other drive and install (aka download; I’m afraid copying the existing install is a bad idea) again.

1 Like

Edit: Sorry I skipped a few messages, at this point you should try protontricks, I just don’t know how to find the corsion of dotnet you need for that game. If it fails redownload.
You are not supposed to install programs for wine through the AUR, that’s what winetricks and protontricks is for.

protontricks is easy, just use protontricks --gui

1 Like

Oh yeah it needs

1. Download the .NET runtime:

there should be a dotnet6 package in protontricks, but it’s strange it stopped working, maybe steam doesn’t move the prefix when you copy something and that’s why it doesn’t work. Or there’s a registry key that wasn’t updated or something, You can “reinstall” it without redownloading everything, if you delete(better to rename, so you have a backup) the game’s prefix, steam thinks you’re running it for the first time and creates a new prefix,

1 Like

Ok, after days of not finding anything, I kinda solved this, but not entirely.

Long story short, Optimus manager seems to create a problem. By switching to ‘hybrid’ instead of ‘Nvidia’ the game can launch (albeit with a few graphical artefact). Now why would this cause a problem ? I don’t know. I should probably submit something on the github for that.

Again, thanks a lot for your answers and your help guys !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.