Problem with Wifi BCM4350 on Yoga 900S

Hi,

I had Antergos on my old Lenovo Yoga 900S and I decided to reinstall OS to EndeavourOS.
On EndeavourOS wifi is not working, but what’s happening is weird.

lspci

02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4350 802.11ac Wireless Network Adapter (rev 08)

Offline install fresh start I do

modprobe brcmfmac

interface is present and I can connect to AndroidAP wifi but not my Unifi wifi.

After pacman -Syyu and restart broadcom is not visible in lspci… I have to make reboot to bios, click F10 and reboot and wifi lcpci is showing broadcom again.
But after this update brcmfmac is saying:

chip backplane type 15 is not supported

So I decide to check broadcom-wl . It is installed by default, so I added just blacklist for brcmfmac.
It is saying that I tainting kernel if trying to load by modprobe wl.
After reboot now Broadcom card is visible in lspci as:

02:00.0 Non-VGA unclassified device: Broadcom Inc. and subsidiaries Device 8100 (rev 08)

I’m lost, what can I try next?

Have you tried anything out of those?
https://forum.endeavouros.com/search?q=broadcom%20category%3A33

I personally don’t have broadcom, but this is source of a lot of problems :frowning:

I read it all.
I checked it again. If I unload wl and load brcmfmac my wifi card is visible in NetworkManager.
Unfortunately I can’t connect to my home network.
I created second ssid with no extra unifi staff enabled and then I can connect. I see that I got 24Mb/s max speed so I guess unifi is disconnecting laptop because of unstable/slow connection.

I’m slowly starting to think about just buying another wireless card…

https://bbs.archlinux.org/viewtopic.php?id=216743

Okay, I fixed the problem by installing the

bcm4350-firmware

package from the AUR. Solved.

You know…That might not be the worst idea :upside_down_face:
Just make sure it’s something good and Linux-friendly at the same time :wink:

welcome

Try uninstalling broadcom-wl and reboot.

after uninstalling interface appears properly! thank you!
any idea why I cannot connect to my main ssid?
it is called 11ska. I can connect to second ssid called hass on 5GHz.
Only difference I see is beginning of the generated MAC address by unifi.

it end up with status_code=16

This is what I see in unifi logs:

Fri Jul 31 16:40:41 2020 daemon.info hostapd: ath4: STA YOGAMAC EEE 802.11: associated
Fri Jul 31 16:40:41 2020 kern.info kernel: [3266630.211030] ieee80211_sta_leave: YOGAMAC
Fri Jul 31 16:40:41 2020 daemon.info hostapd: ath0: STA fc:UNIFIMAC DRIVER: Sead AUTH addr=YOGAMAC status_code=0
Fri Jul 31 16:40:41 2020 daemon.info hostapd: ath0: STA YOGAMAC IEEE 802.11: associated
Fri Jul 31 16:40:41 2020 kern.info kernel: [3266630.252999] ieee80211_sta_leave: YOGAMAC
Fri Jul 31 16:40:41 2020 user.info : wevent[27193]: wevent.ubnt_custom_event(): EVENT_STA_LEAVE ath4: YOGAMAC / 6
Fri Jul 31 16:40:41 2020 user.info : wevent[27193]: wevent.ubnt_custom_event(): EVENT_STA_JOIN ath0: YOGAMAC / 2
Fri Jul 31 16:40:42 2020 user.info : wevent[27193]: wevent.ubnt_custom_event(): EVENT_STA_LEAVE ath0: YOGAMAC / 2
Fri Jul 31 16:40:42 2020 kern.warn kernel: [3266630.755072] [wifi1] FWLOG: [123765425] RATE: ChainMask 3, phymode 1044490, ni_flags 0x06233006, vht_mcs_set 0xfffa, ht_mcs_set 0xffff, legacy_rate_set 0x7440401

Do you have it configured for a different SSID for the 2.4 Ghz and the 5.0 Ghz?
Edit: Normally you would have it configured for the same SSID but some people may not if they have a poor connection issue for some device maybe?

Edit: 2 I would try changing the router to a different channel. Not sure what country you are in. 11 is pretty standard.

I have configured it as same SSID for both channels.
I’m in Poland. I think it cannot be issue with the channel as second SSID is on same channel and it is working for some reason…
it can connect on Windows if it says something.

EDIT1:
Found reason. Broadcom does not connect to network if Unifi fast roaming is enabled.
I guess I’m gonna need to use this second SSID for this card.

Okay no problem I’m not sure exactly what you are saying? The image doesn’t really tell me much. You have one SSID and what is not connecting to it?

Edit: Why do you have two SSID?

“Unifi fast roaming is enabled”

Is this for mobile phone?

one for IOT device, it has blocked internet connection to Chinese cloud etc also on different vlan so harder to crack from outside.

second for “regular” devices like computers, phones with internet. unfortunately I need 802.11r because fast roaming is pretty cool thing if you have 3 access points.

Fast roaming according to unifi:

Enable Fast Roaming
Faster roaming for modern devices with 802.11r compatibility. Older devices may experience connectivity issues

I think card is capable of 802.11r because on Windows it connects.

Oh okay this is something I’m not that familiar with fast roaming. I only have one access point. Is this a setting on the router?

Edit: Okay i see! Unifi. Not familiar with that hardware but i get it!

I think I googled it.
There is some bug with wpa_supplicant.
https://bugs.archlinux.org/task/63397
https://bugzilla.kernel.org/show_bug.cgi?id=206315
https://w1.fi/cgit/hostap/commit/?id=23dc196fde951b3d508f367a603cddffbd053490

I think it should be already in current wpa_supplicant version if commit is from February, but apparently it isn’t

I see because the BCM4350 is older using brcmfmac

KeyMgmt contains wpa-ft-eap and wpa-ft-psk

brcmfmac does not support FT.

do you think that I can do anything for it to work properly?

Is this a desktop? I have broadcom but they are newerTP-link cards with chips that use broadcom-wl-dkms

it’s Lenovo yoga 900s - 2in1 laptop.

Are you using a usb Wifi?

On your image i see 4 different? I see two on channel 11 and two on channel 44. Is this one each on 2.4 Ghz on channel 11 and one each on 5 Ghz on channel 44.