Problem running lutris

I installed lutris the other day and had some problems running it, it gave me some errors and I managed to solve them the only one that remained is this one:

Please check ownership/permissions using:

cd .local/share/icons
ls -l

I get the following:

Try changing icons to default and run ? As it looks that your icons , like whatever custom icons you are using are not having certain icons/are denying lutris some permissions . I also had somewhat similar issue with Infinity Glass Icons on KDE Plasma. Sometimes not having a certain type of icon can also cause lutris to crash.

A good solution would be to stick to default icons oruse a vast well-reputed icon pack e.g papirus, qoogir,etc.

Also please cd into the .icons folder, run ls -a and post the output.

I’m using Qogir


what’s posy_cursor ? Anyways , you on KDE ?

In the icons directory , run sudo chmod -R +rw hicolor

they are a custom cursor. I’m on xfce btw.

1 Like

Run the command and see if fixes lutris.

it says there is no such file or directory

Wait a sec.

So while installing lutris , it must have asked you for choosing a desktop portal package , like xdg-desktop-portal-kde, etc. Which one did you choose ?

I don’t remember it asking, sorry I just installed it through Yay

okay then , according to an old thread here :

1.Try installing the appmenu-gtk-module.
2.Create a directory in the icons folder named hicolor.
3.Run the command I gave you earlier after cd-ing into the icons folder.

still the same error

well strange , try running sudo pacman -R xdg-desktop-portal-gnome && sudo pacman -S xdg-desktop-portal-kde kdialog.

Alternatively you should run sudo pacman -R xdg-desktop-portal-gnome && sudo pacman -S xdg-desktop-portal-gtk instead if on XFCE

sorry didnt see the edit.

neither worked tho lol

remove everything before && along with && and run the second command. Along with the output .
And please paste the text output .

ok it installed the thing

[hectorm@Seren icons]$ sudo pacman -S xdg-desktop-portal-gtk
resolving dependencies...
looking for conflicting packages...

Package (1)                   New Version  Net Change  Download Size

extra/xdg-desktop-portal-gtk  1.15.1-1       0,45 MiB       0,11 MiB

Total Download Size:   0,11 MiB
Total Installed Size:  0,45 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 xdg-desktop-portal-gtk-1.15.1-1-x86_64              112,4 KiB   450 KiB/s 00:00 [----------------------------------------------] 100%
(1/1) checking keys in keyring                                                   [----------------------------------------------] 100%
(1/1) checking package integrity                                                 [----------------------------------------------] 100%
(1/1) loading package files                                                      [----------------------------------------------] 100%
(1/1) checking for file conflicts                                                [----------------------------------------------] 100%
:: Processing package changes...
(1/1) installing xdg-desktop-portal-gtk                                          [----------------------------------------------] 100%
Optional dependencies for xdg-desktop-portal-gtk
    evince: Print preview
:: Running post-transaction hooks...
(1/3) Reloading user manager configuration...
(2/3) Arming ConditionNeedsUpdate...
(3/3) Updating the desktop file MIME type cache...

Now try running lutris.

still the same error

[hectorm@Seren icons]$ lutris
2024-03-24 23:28:53,575: Starting Lutris 0.5.16
Traceback (most recent call last):
  File "/usr/lib/python3.11/site-packages/lutris/gui/", line 480, in do_command_line
  File "/usr/lib/python3.11/site-packages/lutris/", line 155, in init_lutris
  File "/usr/lib/python3.11/site-packages/lutris/", line 45, in init_dirs
  File "/usr/lib/python3.11/site-packages/lutris/util/", line 401, in create_folder
    os.makedirs(path, exist_ok=True)
  File "<frozen os>", line 215, in makedirs
  File "<frozen os>", line 225, in makedirs
PermissionError: [Errno 13] Permission denied: '/home/hectorm/.local/share/icons/hicolor/128x128'
2024-03-24 23:28:53,578: Shutting down Lutris

Perhaps try removing appmenu-gtk-module ?