Printing not working

I’m trying to setup a hp printer but it gives a cups network error.

When I try to run hp-setup I get this:

[kiran@kiran-81w4 ~]$ sudo hp-setup -i

HP Linux Imaging and Printing System (ver. 3.22.10)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a ‘*’. Press to accept the default.)


Num Connection Description

0* usb Universal Serial Bus (USB)
1 net Network/Ethernet/Wireless (direct connection or JetDirect)
2 par Parallel Port (LPT:)

Enter number 0…2 for connection type (q=quit, enter=usb*) ? 1

Using connection type: net

error: No device selected/specified or that supports this functionality.
[kiran@kiran-81w4 ~]$

I did select the hp printing option in the installer.

First, printing sucks on Arch in my experience.

I have an HP printer as well. And even for wireless printing I need to set up with a cable.

You need the ‘hplip’ package, not cups.

Connect your printer with USB and run hp-setup as sudo.

Go thru so the whole process.

Did you select printing on the install? This is what install cups.

From post 2 -

There’s two options. I wasn’t sure of the HP printing option as i never used it before. I always select printing which installs cups and related packages.

Edit: I guess it probably installs printing support geared towards HP?

It should install hplip, which should be all anyone with an hp needs (it’s all I install for my HP 4500)

I’m sure it’s just a matter of how one goes through the setup to install the printer. Hp is a little different so i hear. I use brother and a canon but both are usb not network printers.

Most of the HP drivers are closed source and will need hplip. It’s not a matter of setup. It’s a matter of the drivers.

Well as I said I’m not sure what gets installed when you select the HP printer support on the installer. I am assuming it installs hplip? Or is it just installing the HP setup utility? :man_shrugging:

maybe firewalld… just idea

1 Like

I have hplip and cups, and im following the steps that worked perfectly on bare arch linux

and there isnt any usb thing on my printer

Have you looked at the discovery page. It tells you how to install an HP printer. It also goes over the firewall and avahi if it is a network printer.

Yeah I’ve done everything there. still no luck.

these instructions worked fine on plain arch. is there anything im missing?

I can’t just explain how to do it without seeing it and knowing what you are doing and what the issue is?

I’m trying to setup a priter with the print settings ui, and it gives me this cups server error. I have hplip and cups installed. Are there any logs I can give for this?

You can check if cups service is running.

systemctl status cups
     Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; preset: disabled)
     Active: active (running) since Sat 2022-12-24 18:58:01 EST; 33min ago
TriggeredBy: ● cups.socket
             ● cups.path
       Docs: man:cupsd(8)
   Main PID: 544 (cupsd)
     Status: "Scheduler is running..."
      Tasks: 1 (limit: 8732)
     Memory: 157.0M
        CPU: 13.591s
     CGroup: /system.slice/cups.service
             └─544 /usr/bin/cupsd -l

Dec 24 18:58:01 kiran-81w4 systemd[1]: Starting CUPS Scheduler...
Dec 24 18:58:01 kiran-81w4 systemd[1]: Started CUPS Scheduler.
Dec 24 19:17:29 kiran-81w4 cupsd[544]: pam_unix(cups:auth): check pass; user unknown
Dec 24 19:17:29 kiran-81w4 cupsd[544]: pam_unix(cups:auth): authentication failure; logname= uid=0 
euid=0 tty=cups ruser= rhost=localhost```