Printing (Canon using bjnp protocol)

If you have installed EOS and want to get a Canon printer working over wifi using their proprietary bjnp protocol

  1. install cups and cups-bjnp
  2. start cups service (systemctl enable cups.service, then systemctl start cups.service)
  3. install the cnij drivers for your printer (ex: cnijfilter-mg3600series) from AUR
  4. open browser, go to localhost:631 which is the web interface for CUPS
  5. click “add printer”, and finish the install

Should go smoothly. The thing many users get stuck is that Canon uses this bjnp protocol, and that causes much confusion. Hope this saves somebody some time :slight_smile:

4 Likes

A little background. I am reviving this old thread as the situation seems to fit my use case, but feel free to move it to it’s own topic.

I have a Canon PIXMA TS3151 wireless printer which @ricklinux and @pudge helped me get working on Plasma.
But these days I have the shiny new Gnome 42 and now I want to install the same printer.

Once I created the groups lp and lpadmin and cups and added myself, I enabled/started the services.

systemctl -a list-units | grep -i cups

and they are up and running.

Screenshot from 2022-04-15 13-01-50

and I modified the /etc/nsswitch.conf according to an article by @joekamprad
and installed avahi.

image

Installed the cups-bjnp and added the printer in CUPS interface.

Screenshot from 2022-04-15 12-33-47

Not sure if it’s important, but there is an iMac on the network running CUPS (they created CUPS of course :thinking: but our one is a fork of it) so it correctly identifies the printer as being on @iMac. I’m wondering since the CUPS server is running on iMac, this could be a network problem, as it printed before on the same home network. The print spooler on the mac is empty.

Here are the CUPS pages.

Screenshot from 2022-04-15 12-35-07

Screenshot from 2022-04-15 10-07-52
Screenshot from 2022-04-15 10-13-19

then it times out without printing.

Here is the printer installed in Gnome

image

I have disabled firewalld for the time, just to be sure.

Here the portscan does not detect the Canon printer.

image

What am I missing here?

Not sure how you are trying to install the printer? It may already see the printer but are you trying to install a network printer?

Edit: https://discovery.endeavouros.com/printers/printers/2021/03/

Not a network printer, but CUPS detects it on the network. Printer specs below. This computer is connected to the router by ethernet. The printer is wireless, but has a USB port, but I pref wireless, since we print to it from Mac with out a problem. Hope that clarifies.

What about just removing all the printing related packages and services? I have tried packages like cnijfilter2 and https://aur.archlinux.org/packages?O=0&K=cnijfilter-common and they are probably still running.

I don’t understand what you are getting at here. If you are trying to install the printer it is wireless. You need to have nss-mdns installed and avahi-daemon.service running. Then you should be able to add it.

Everything is on the wiki page a posted the link for wireless printer setup.

nss-mdns is already installed.
image

Edit: Here’s another one

Thanks. Trying it now.

image

How do I find out which files are conflicting?

Thanks

Do you already have a package installed?

I uninstalled cnijfilter2 and cups-bjnp
It still does not print
image

I’m not sure what you are doing. You install the drivers and as far as i know it should be added as a network printer using ipp because it’s wireless & has to connect to a network. :man_shrugging:

It finally worked, but I thought it was worth some explanation, so members benefit from the topic in future.

It did not work with IPP, but it worked with Canon driverless.

I was not so stressed to get the printer working as I was still able to print from the iMac wirelessly, or at least so I thought. Wife informed me she could no longer print from the iMac. It was unlikely to a problem with two computers, so I reset the Canon printer to defaults, and voila! I was printing from the iMac.

I opened up CUPS on the :enos: and a new driver appeared in the CUPS driver list: Canon TS3100 series, driverless, cups-filters. All I had appearing were CUPS-Braille and CUPS-PDF. So it ends well and the advice on this post works, Thank you Rick.

So if all the services are running and it still won’t work, try resetting the printer to defaults.

Cheers! :beers: