Cant print to networked printer via CUPS

I got cups installed and it finds the printer, but after it gets added I can not print to it. I can find the printer but when I print in Cups it gives me the error : Processing - “Unable to locate printer “BRN008092968D65.local”.”

This is my printer version: Brother_MFC-J435W

Sounds exactly like what I experienced with my Brother printer.
Here is my thread and the solution:

when I try to edit the nsswitch.conf it wont even let me with SU. do I need to stop a service before I edit that file or something?

I was able to edit the file but still having the same problem…

Since the MFC-J435W is not in the AUR, give me a few minutes and I will build you a PKGBUILD for the MFC-J435W.



thanks a bunch!

OK so it took a little longer than a few minutes. I know this is a long post, but this will give the best chance of this being a learning experience.

I went to the Brother Web Site and found the Advanced User’s Guide for your printer.
The guide said it was for the following Brother Printers:
So we now assume that the drivers for these 3 printers are very similar.

Next, I hopped on over to the Arch AUR. A quick search found the following packages
brother-mfcj425w & brother-mfcj430w – brother-mfcj435w was NOT there
From the brother-mfcj425w AUR page, did a “Download snapshot” and unzipped the file.
Which yields the following files:
brother-mfcj425w.install – PKGBUILD – .SRCINFO

Now it was a matter of editing all the files, and substituting all references of mfcj425w to mfcj435w. Then getting sha256sum for the new .rpm files. I ensured that pkg lib32-glibc was installed and ran
makepkg PKGBUILD.
Voila, it compiled no problem.
As I don’t have a MFC-J435W I cannot test the final product, but it should work for you.

So now, you can download the revised “snapshot”

After downloading, from your favorite file manager, in your home directory, make a folder named /home/user/Brother or whatever pleases you. Copy the downloaded tar package into this folder.
Go to this folder and double click on the tar.xz file and hopefully file roller will offer to extract the files into the Brother folder. Change into the extracted folder. You should see
brother-mfc-j435w.install – PKGBUILD – .SRCINFO
Remember .SRCINFO is a dot file or hidden file. Use ls -al to view the files.
With a text editor, list the individual files and look them over real close.
After inspecting them, if you feel they are safe and nothing fishy going on, and you decide to trust me, you can compile it.

In a terminal cd into the Brother folder and do the following:
$ pacman -Q lib32-glibc
If lib32-glibc is not listed, install it with sudo pacman -S lib32-glibc
Still in the Brother folder, as user (not sudo or root) do the following:
$ makepkg PGKBUILD (this will compile the pacman package, but NOT install it).
After the compile finishes, you should find a file named

Put the .pkg.tar.xz file on a USB thumb drive or someplace safe for next time you want to install the printer on an Arch based distribution. Since the last update on the drivers (3.0.1) was in 2013, it is safe to say no further driver development will be performed for this printer. So you can erase all the files in the Brother folder, except the brother-mfcj435w-3.0.2-1-x86_64.pkg.tar.xz file.
To install it, from a terminal window in the folder that contains the pkg.tar.xz file
ensure that lib32-glibc is installed.
ensure that cups and cups-pdf are installed and org.cups.cupsd.service is enabled in systemd
$ sudo pacman -U brother-mfcj435w-3.0.1-1-x86_64.pkg.tar.xz
from a browser go to localhost:631 and install the drivers. Use ipp and enter the IP address of the printer ipp://192.168.0.XXX
chose this driver Brother MFC-J435W for CUPS en

for the scanner
$ yay -S brscan4
If the printer is connected on the ethernet LAN, and not a USB port on the computer. Then after yay -S brscan4 enter as root
# brsaneconfig4 -a name=“Brother” model=“MFC-J435W” ip=“192.168.0.XXX”

The above is what I had to do to get my Brother DCP-L2550DW installed properly. Have used the resulting .pkg.tar.xz file numerous times since.



It worked thank you so much!!!


You are very welcome. To thank me, do the following:
Save the text of post # 7 into an archive such as zim, or as a text file on a thumb drive containing Linux secrets. What!..we all have secret thumb drives, right?

Save the down loaded archived package and the resulting .pkg.tar.xz pacman package on the aforementioned thumb drive.
Next, enjoy the feeling of something accomplished.

Have fun with EndeavourOS.



I am thinking this may be a case of no drivers too, so in that hope am replying to you @Pudge

The Canon PIXMA TS3151 (appears in CUPS find printers as Canon PIXMA TS3100 Series + Gutenprint v5.3.4) and appears in Settings > Printers in driver search as the same. The paper size is correct A4, the same setting as the printer.

Once I do a TEST print either from CUPS (localhost:631) or EOS Settings, no data is sent to the printer. I can ping the IP of the printer.

The closest driver match in AUR for TSxxxx models:

Here is a screengrab of CUPS status page.

sudo systemctl -a list-units | grep -i cups
[sudo] password for michael:
cups.path loaded active running CUPS Scheduler
cups.service loaded active running CUPS Scheduler
cups.socket loaded active running CUPS Scheduler

I am not sure what else to try. I had the printer working with Manjaro by doing what I described above. Can you also suggest a scanning package, as I had Skanlite working on Manjaro, and of course how to install it.

I am a member of the lp and cups group. Maybe it is time start disabling services, but I will wait for wiser heads to reply.

Let me now if you need system and hardware specs, but I doubt it, since it ran on Manjaro.

Thanks in advance.

I know Brother printers, but I know nothing about Canon printers or their drivers.
There are some users on the forum with Canon printers, maybe one of them can help.

In the mean time, here are some Topics on Canon printers, hopefully one will help you.

If none of those help, go to the search icon to the left of your avatar and enter “Canon printer” there are more Topics beyond the above mentioned.


I just had a brief look and I will try the bjnp. THanks for the responding so fast.


1 Like

network printers mostly needs local hostname resolutioon to be enabled:

Avahi provides local hostname resolution using a “hostname.local” naming scheme. To enable it, make sure the nss-mdns package is installed and avahi-daemon.service is running:

pacman -Qs nss-mdns to see if it is installed local:

➜ ~ » pacman -Qs nss-mdns
local/nss-mdns 0.14.1-3
glibc plugin providing host name resolution via mDNS

Make sure avahi-daemon is running:

systemctl status avahi-daemon.service

Then, edit the file /etc/nsswitch.conf and change the hosts line to include mdns_minimal [NOTFOUND=return] before resolve and dns


Thanks @Pudge, the did the trick. It installs driverless, cups filters, but it only prints monochrome. I may try the bjnp protocol later, but I can live without color for now.

Should I write up a clean SOLVED post to help others from going down my 6 hour rabbit hole?


I think we are good with all the other topics on the subject. I will mark this Topic as solved.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.