How do I install canon printer

I am not able to install the printer driver for my canon G6000

Did you add printing support (cups) during the install process?
If not, you can always install it with pacman.

I had trouble to install my HP printer too but I found this website which helped a lot.

It helps for various brand and they have topics for Canon printers.

Have fun !

What I need is instructions on how to install the driver I have downloaded from Canon. In Ubuntu I would use “Gdebi” to install it. What do I use in Endeavour?

Installed it in the installation process. I checked, it is running.

You should be installing the driver from the AUR.

yay -S canon-pixma-g6000-complete

Edit: It’s in the AUR

[ricklinux@eos-kde ~]$ yay -Ss canon g6000
aur/canon-pixma-g6000-complete 5.90-1 (+1 0.00) 
    Print Scan for Canon PIXMA series E3340 G5040 G5050 G5070 G6040 G6050 GM2050 TS3340 TS3350 TS3351 TS3352 TS3355 TS5340 TS5350 TS5351 TS5352 TS5353 TS6340 TS6350 TS6351 TS8340 TS8350 TS8351 TS8352
[ricklinux@eos-kde ~]$ 
1 Like

Thank you. I will try and do that. Appreciate your help.

1 Like

This is the complete driver so it should have scanning also. I have a cheaper Pixma Canon 2525 and it works with a similar AUR package. So as long as the package builds and installs you should have no issues as cups should be installed.

Edit: If you’re not familiar with the building process from the AUR to install a package just read what it says so you get an understanding how it works. For the most part you probably should be able to just press enter for the default on each and it may ask for your password.

I tried to install the driver and it is still not working. Followed your package above. I may be doing something wrong as I am not familiar with ARCH linus. Newbie!

I don’t know what you are doing. You just install the AUR package and then go to print settings and add your printer.


Thank you so much for your help. Finally got it to work. Was not installing it correctly. Caught my mistake finally. Your instructions are very helpful. Thank you, again, for this newbie.

No problem. It’s also sometimes hard to explain when i don’t see what is happening. Was your issue with the package build? Or something else?

Edit: It’s also not the same process for every printer so it can be challenging.

Missed an initial selection. Once I said “n” it worked flawlessly. Thanks, again.

1 Like