Post Install Clean Up Error

Hey guys! I just tried installing i3 edition on my PC two times and had the same problem both times:

External command failed to finish

Command /usr/bin/ failed to finish in 500 seconds. There was no output from the command.

If I am not mistaken the last line on the installer log when this error happens is:

pacman -s —needed nvidia-dkms

or something like that. I found a post on the same problem ([not a bug] The installer crashed while trying to install online with manual partitioning)
and the reason was the poster tried to install with NVIDIA drivers instead of nouveau with a legacy chip. However, I have a GT 1030 and it is still supported in latest NVIDIA drivers. I always install with proprietary drivers on other distros without any problems. Any solutions?

Update your mirrors first. It probably didn’t find the packages on the mirror it tried to download them from. This happens and it won’t install if packages are missing.

The other thing you can do also is add nvidia-dkms in the user_pkglist.txt file on the live ISO. Just open a terminal after loading the ISO and use the text editor to open the file and add this package to the file and then save it.

sudo xed

Then update the mirrors first from the welcome app. Make sure you make selections and not just click update and let it do it. Select country and number of mirrors.

Hopefully this works.

I updated mirrors both times so thats not it. What is the path of that file? Also what is sudo xed?

A better response would be i tried that on the last two attempts. Do you still think i should update the mirrors again?

the timeout for the cleaner script is in some cases a bit short… if you got some connections slow down or other network related issue …
You can set the timeout for the module bigger and there sudo xed comes in handy :wink: it will start texteditor with admin rights.

sudo xed /etc/calamares/modules/shellprocess_chrooted_cleaner_script.conf

and change timeout: 300 to something bigger like 600 …

1 Like

I totally forgot about this it’s been so long since I’ve seen it used. :slightly_smiling_face:

Edit: xed is a text editor on the live ISO in Xfce. Use sudo for admin privileges to be able to save the file.