Plugged Headphones as Unplugged

Hi, I’ve been trying to setup my (wired) headphones successfully on EOS (KDE) for the past few days without luck.

My issue is that the headphones are listed as “Headphones (unplugged)” in both pavucontrol as well as the audio settings of KDE.

But, when I select that as an output channel instead of my laptop speakers, and tap the volume bar (which tests the audio with pop sounds), the headphones do play the sounds.

What is weirder is that every time, given enough time (like 15-20 minutes from login), it suddenly recognizes the headphones when I check the sound settings again and then it plays using it without any issues (including while typing this very post).

I’ve tried alsamixer, which has entries for sound cards as shown:

-              (default)
default:0  HDA Intel PCH

Selecting the first one (which is default), it gives only one slider labelled “Master” going from 0-100 and changing it only changes the speaker volume.

Selecting the second entry gives 8 sliders, first being for “Headphone”, second to “Speaker”, and third for “PCM” and so on.

When the headphones are detected as “unplugged”, increasing “Headphone” volume (it starts from 0) does allow audio to start playing at specified volume in my headphones, but at the same time it also plays it with the same volume on my speakers as well. Also, muting the speakers in this situation mutes both headphones and speaker as well.

I don’t exactly know what details to put here, so I’ll add the details I saw in other similar forum posts. Please do let me know if you need anything else.

$ pactl info
Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 681
Tile Size: 65472
User Name: resyfer
Host Name: EOS
Server Name: PulseAudio (on PipeWire 1.0.0)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_1f.3.analog-stereo
Default Source: alsa_input.pci-0000_00_1f.3.analog-stereo
Cookie: 72df:2f8e
$ inxi -Fzx                                                                                                                                                        130 ↵
  Kernel: 6.6.9-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: KDE Plasma v: 5.27.10 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 3501 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0XGX0C v: A00 serial: <superuser required> UEFI: Dell
    v: 1.27.1 date: 10/03/2023
  ID-1: BAT0 charge: 29.6 Wh (100.0%) condition: 29.6/42.0 Wh (70.5%)
    volts: 12.6 min: 11.4 model: SMP DELL VM73283 status: full
  Info: quad core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 8 MiB
  Speed (MHz): avg: 549 high: 850 min/max: 400/4200 cores: 1: 400 2: 733
    3: 400 4: 400 5: 813 6: 400 7: 400 8: 850 bogomips: 38720
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
    driver: i915 v: kernel arch: Gen-12.1 bus-ID: 00:02.0
  Device-2: Microdia Integrated_Webcam_HD driver: uvcvideo type: USB
    bus-ID: 1-6:4
  Display: x11 server: X.Org v: 21.1.10 with: Xwayland v: 23.2.3 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: iris,swrast platforms:
    active: x11,surfaceless,device inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.2-arch1.2
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Xe Graphics (TGL GT2)
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  API: ALSA v: k6.6.9-arch1-1 status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlan0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
    v: 0.8 type: USB bus-ID: 1-10:5
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
  Local Storage: total: 1.14 TiB used: 135.79 GiB (11.6%)
  ID-1: /dev/nvme0n1 vendor: A-Data model: IM2P33F3A NVMe 256GB
    size: 238.47 GiB temp: 29.9 C
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
  ID-1: / size: 75.44 GiB used: 13.53 GiB (17.9%) fs: xfs dev: /dev/nvme0n1p6
  ID-2: /boot/efi size: 511 MiB used: 300 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p4
  ID-3: /home size: 400 GiB used: 122.26 GiB (30.6%) fs: btrfs
    dev: /dev/sda3
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p5
  System Temperatures: cpu: 56.0 C mobo: 41.0 C
  Fan Speeds (rpm): cpu: 0
  Processes: 265 Uptime: 8m Memory: total: 8 GiB note: est.
  available: 7.49 GiB used: 2.63 GiB (35.1%) Init: systemd Compilers:
  gcc: 13.2.1 Packages: 1216 Shell: Zsh v: 5.9 inxi: 3.3.31

I suspect that this is an issue with KDE. I had this problem on a previous install of Garuda Linux, and now have the same problem here on EndeavourOS. I’ve found this issue in a couple other topics (such as this one and a couple posts on the Manjaro forum), but never any solutions. Did you end up finding anything?