Plasma Stutters on Nvidia Wayland

I have installed the proprietary NVIDIA drivers using nvidia-inst --32 and Games do work smoothly most of the time, but plasma itself stutters a lot. Using the desktop effect Show FPS I can see that KWin isn’t running at my monitors refresh rate (144 Hz) most of the time. It usually hovers at about 100 when moving windows, and I have seen it drop to about 30 fps. I’m guessing that hardware acceleration isn’t working.

Greetings @Tikaiz! :wave: :sunglasses: :enos_flag:

Can you confirm, you’re running a fully up-to-date system?

eos-update --yay --nvidia

I have run that command, the nvidia drivers are at version 555.58.02-1,
After a reboot I can no longer get into a plasma Wayland session, it just creates a new X11 session. I even started plasma from a tty using startplasma-wayland but the graphics platform in About this System reports X-11.

For clarity, that script is a helper that performs a full update of installed packages and AUR, in the same way running yay would, except it includes a few additional helpers to keep certificates in sync and such.

At this point, it might help to know a bit more about your system, such as your desktop environment and such.

I am using KDE plasma, the following is pasted from the About this System page in the System settings app.
Operating System: EndeavourOS
KDE Plasma Version: 6.1.1
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.2
Kernel Version: 6.9.7-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600X 6-Core Processor
Memory: 15,5 GiB of RAM
Graphics Processor: llvmpipe
Product Name: B550 Pro4
Graphics Card: NVIDIA RTX 3070
If you need any more information let me know.

I apologise @Tikaiz, you had actually dropped the hint that you were running KDE Plasma, I just missed it :sweat:

When you try to login with Wayland, what is happening? Does it take you back to login? Be fairly clear if you can, because there’s a number of different traits to watch out for with Nvidia + Plasma/Wayland.

Firstly, sddm also has some issues, it confines the cursor to a rectangle in the upper right corner, the mouse inputs are scaled to the entire screen so I can still click on everything, even though I am not hovering over anything.
When I log in the Screen goes black, the initial login went fine and it was using Wayland but I was having the same issue as in sddm. I then logged out and back in and it took a really long time to load, I noticed the scaling of the splash screen was smaller, and then the desktop appeared.
I checked on a tty and it is still using kwin-wayland so that’s why I’m so confused, because all the different settings that are only available in Wayland were not in the settings and the graphics platform reports as X11, maybe the plasma-shell is running under Xwayland?

If I’m understanding correctly, you’re now able to log in with Wayland, but you encountered some inconsistencies between tries?

sddm having issues is also strange. Other than the stuttering, were you encountering these sorts of issues before running the update?

The reason I started with the update, is Nvidia released a long awaited update (v555) that was aimed at resolving some of the Wayland issues. That said, I still use X11 here, because I still have some issues (mouse position weirdly offset in browsers and such).

Some members, such as @ricklinux have had much more success with Wayland + Nvidia.

I have no issues with Wayland on Nvidia. I am using a GTX 1060 gpu with 555.58-2 drivers.

1 Like

Sorry if you didn’t understand what I meant to say, English is not my first language.
I am currently able to select a wayland session from sddm and log in, but KDE reports it as being an X11 session.
I went into a different tty and looked at the currently open applications and kwin-wayland was listed there.

What is the bios version of your board? Is it an Asrock B550 Pro4?

Yes it is the model you specified, I have just recently(2-3 weeks ago) updated the bios, due to an unrelated issue.

I see the version is 3.40 and they have a 3.41 Beta out now. Just wondered if you had the 3.40 current version?

I checked and I have version 3.40 installed

After another reboot I can now login to the wayland session and It actually uses wayland now according to plasma, the cursor issue was still present, I have dropped the scaling factor to 100% and the cursor issue is gone for now.

1 Like

Why did you have scaling set higher?

because I have a semi-high resolution monitor at 1440p and everything is too small at 100%, I would like to be using 125%.

Also now whenever I maximize an Application the entire Screen goes black and the desktop restarts, so I’m guessing the compositor is crashing.

1 Like

What is the monitor running set at 100% scaling?


What is the monitor model? Maybe there are some setting you need to change in the monitor settings that would help?