Pinebook Pro: Lightdm fails to start on first boot. "Can't launch X server X, not found in path"

EDIT: SOLVED… xorg didn’t get installed. pacman -S xorg-server fixed the problem.


Hi

I’ve installed EndeavourOS (xfce) on my Pinebook Pro verbatim from the instructions provided.

Upon first boot after running the installer script (endeavour-ARM-install-V2.4.sh), Lightdm fails to start.

After running lightdm --test-mode --debug, I get this error:

Can anyone assist? Let me know if I need to provide any other logs.

Thank you

2 Likes

what if
you go to tty and do:

sudo systemctl enable lightdm
sudo systemctl start lightdm

look like you solved it @cowsay

nice see another Pinebook pro user here :+1: pls mark solved

2 Likes

Oh yeah, I forgot that was a thing. :slightly_smiling_face:

Also, I set this up with f2fs instead of ext4. For anyone interested in doing the same, you can see my post here… just one small edit to the installation instructions.

https://forum.pine64.org/showthread.php?tid=14238&pid=99009#pid99009

1 Like

Hmm strange xorg-server no install . :pray: point this out, I try test install after work .

@Pudge

1 Like

Ya there were a few quirks that I noticed so far. Otherwise, everything I tested seems to work well.

  • No xorg-server
  • No sudo
  • NetworkManager not enabled by default
  • No browser installed (that might be intentional)
  • Edit: Also, there was no EndeavourOS styling for the XFCE theme like the standard installers provide (again, maybe intentional) Edit2: I think it is failing to install dotfiles from endeavouros-xfce4-theming
  • Edit3: No welcome app installed, yay also missing

This is what the installation looks like by default for me (no EOS styling):

1 Like

:pray: for reporting this . I sorry for your trouble , I try fresh test install after work see if get same .

1 Like

I installed EndeavourOS with i3 in my pbp on the eMMc and I believe nothing is missing.

1 Like

I had a problem recently with f2fs after setting up an encrypted file system on an SD card (after some use the structure needed cleaning, this happened twice so I gave up), but the SD card might me defective, ext4 also gives me trouble, only fat seems to work.

So probably it is nothing to do with f2fs but SD cards can be problematic.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.