Pia vpn client does not always autostart part 2

I made this post [Pia vpn client does not always autostart] a while ago. I wanted to follow up and post the solution.

The problem is exactly as the title says.

The solution for me is in KDE plasma I had to go into system settings - workspace - startup and shutdown - desktop session - session restore - and select the start with an empty session.
Once I did this private internet access has started without fail every time I start the computer.
I hope this helps someone.

1 Like