Photoshop CC 2019 running in the latest EndeavourOS

I know that subject is going to sound like a troll popping up, or illicit a lot of groans about this application running in Arch or Linux in general but with Wine 5.0… I have been to the mountain top, and it is good.

It even sees my 2080Ti as a graphics accelerator. The short version is:

  1. Boot into Windows 10, install Photoshop, run once, make sure it’s working, activated, etc.
  2. Boot back into Arch, open Lutris, make sure the Wine version lutris-monsterhunter-5.0-x86_64 is installed. If it isn’t, just go to the gear next to Runners in the main window, scroll down to Wine, click the toolbox and find it in the list, check the box and it will install. Open Wine Configuration, and change your OS version from Windows 7 to Windows 10. Save the settings.
  3. Add a game to Lutris with the plus sign menu. Call it Photoshop, find the directory on your Windows drive (or if you copied it over to your Arch drive find it there) and set Photoshop.exe as the executable.
  4. Under runner options settings are as follows:

Save the configuration, I suggest opening the Log for Photoshop by clicking the little terminal icon, and then click Play and hopefully Photoshop will load up without an issue. Then configure as desired. I disable the new home screen personally.

This was more “Can I make this work?” than “I think this is a viable production system replacement option.” if you’re trying to get out of Mac/Windows land permanently. I’ve been trying this for a year or more now as new Wine point releases came out and this is the first time I’ve ever gotten into the application.

The one strange behavior I’ve had is that Ctrl + Z undoes an action, but in the instance of a brush stroke, the canvas doesn’t redraw until you make another stroke, which would definitely make this a deal breaker for a professional artist. However, what a neat step Wine has taken with the 5.0 release, even if it needs a custom spun build for this to work. Edit: Workaround seems to be just select all so the border is constantly ticking around the outside of the canvas, and Ctrl + Z undoes the stroke properly, I’m assuming because the select all is constantly redrawing the canvas for the ticking effect.

And yes, I used the Gaussian Blur tool to blur out parts of my terminal. :smiley:

Happy tinkering!

8 Likes

No :wink:


OT:
I do not like PS since version 2.5 (1992, after 2 years of use :wink: ).
Since when I can’t stand Adobe I don’t know any more :smiley:

2 Likes

I’ma reply here as a bookmark. This is great, thanks for writing this.

1 Like

You know that you can bookmark inividual replies and comments without bread-crumbing?

It’s under the “hamburger/the three dots”.

3 Likes

Great to know that aswell, Mr_Ecks, but I actually also wanted to sincerely thank Hexidecimal for taking the time to write all this. The gesture itself made me glad, and definitely deserves recognition.

4 Likes

Thanks @Hexidecimal !

Edit, easier fix: Enable NIVIDIA Prime render offload in the system option tab of your Lutris configuration.

To fix your strange behavior, just configure your Photoshop in Lutris. System options tab, then command prefix, and add: env __GL_MaxFramesAllowed=1

This is because you’re using a Nvidia GPU, and there is a frame delay bug, fixed adding this parameters.

2 Likes

Thank you for the fix :partying_face:

1 Like

Another improvement. To create a propre file association, create a new .desktop file:

nano ~/.local/share/applications/wine-extension-photoshop.desktop

Paste this and edit according to your path:

[Desktop Entry]
Type=Application
Name=Adobe Photoshop 2020 IMG
Exec=env __GL_MaxFramesAllowed=1 /home/artik/.local/share/lutris/runners/wine/lutris-monsterhunter-5.0-x86_64/bin/wine start /ProgIDOpen Photoshop.Image.21 %f
NoDisplay=true
StartupNotify=true
Icon=726B_Photoshop.0

Now you can add any image file association, and Photoshop will properly open, ready to edit the image.

1 Like

Unless there is a very very good reason, use GIMP which, for 99 % of the tasks, is just as good as Photoshop. After switching to Linux full-time, I learnt GIMP. With plugin registry and GMIC, it is pretty awesome.

I still have a windows VM at hand for photoshop. my customers can’t be bothered with my philosophies.

other than that, even if you don’t have a very good reason to use windows apps on linux, you can do it just because you like them more, or simply because you want to:)

There’s really no limit what you can do and not do on your own machine.

@subluminal: I get where you’re coming from (if you don’t give linux apps a chance, you’re going to be stuck with windows apps), but still, to each his own.

PS. To this day I didn’t find a program on linux as capable as notepad++, and I’ve tried a lot of them. (Right now I’m using medit, which comes closest, but it’s still pretty far away). Every Linux editor out there lacks some of its features. I find it too cumbersome to use it via wine, but my point is, some things are still better on Windows.

2 Likes

Hello!!!
What you discover is really awesome but unfortunately i couldn’t make it work today at June 14. Do you know if is still working today ? Because i tried but it didn’t work =( .

Be well!

More detail needed.

hello! It’s not still necessary. I found a Photoshop CC for Linux.
Thanks anyway =).

Be well!

…and…thank you for sharing it here with the rest of us…?

2 Likes

Yeah, it’s called GIMP. :rofl:

3 Likes

:zipper_mouth_face:

2 Likes

I have been working on a Crossover archive of Photoshop 2018 CC. But sharing it would be infringing copyright.

Absolutely not. What part of infringing copyright don’t you understand?

Do NOT solicit illegal behaviour from other members.

@Kresimir :parrot: :question:

1 Like