Permissons for Lightdm to show user wallpaper?

What are the permissions I need to change for Lightdm to be able to show user wallpaper? It works by default in Ubuntu-based and in Manjaro, but not in pure Arch and EOS, so a permission must be different.

1 Like

Not sure I understand the question - but I will note that in XFCE I just go Settings/LightDM, enter a sudo password, and tick the box for using user wallpaper if available… You could also specify the background by full path/name in the same place. Don’t know if your setup includes this, though…

This is what doesn’t work in Arch / Endeavour; if I set permissons on my user directory as Ubuntu’s defaults are, lightdm can switch background without me copying my wallaper to the /usr/share/backgrounds folder.

Ahh. Didn’t realize that you didn’t keep them in backgrounds… I just ‘always’ have… Glad you found a way to get it done.

1 Like

Apparently the default settings for debian based systems are the equivalent of running

sudo chmod -R a+rwX,o-w /home/$USER

in an Arch based system but set as such as default.

in lightdm/gtk-greeter you can use also your current desktop wallpaper. otherwise you have backgrounds in /usr/share/XXX somewhere.

It sounds odd to me - but I guess that would make the difference. I just took a quick look on an Ubuntu (Rolling Rhino) system, and /home/username has the same permissions as /usr and /bin (for example). drwxr-xr-x instead of drwx------

Not too sure why they do this, but I can see it will let external processes access your home directory. I think I prefer the ‘Arch way’, though - as other users/groups don’t get r-x access in my home!

Of course, I could be wrong about this - it wouldn’t be the first time (or the last).

That’s what has never worked for me on any Arch distro, I must have the wallpaper in /usr/share/(folder) or Lightdm can’t change it. Unless I run

sudo chmod -R a+rwX,o-w /home/$USER

The greeter sessions run per default with the user lightdm AFAIK, so this user would need read access to the home directory.

I also have this error, that apparently is connected to the gnome keyring and has been persistent for Xfce - on - Arch for over a year.

lightdm[939]: gkr-pam: unable to locate daemon control file

Might be connected?

for after notice next ubuntu release wil get this :slight_smile:

That has been going on a lot longer then that. yes it is related to gnome-keyring. The only way i have found to remove that error is to remove gnome-keyring.

1 Like