Pcmanfm-qt doesn't show icons

Last time I installed the LXQt desktop environment with the sudo pacman -S lxqt command. There is a problem described in the topic title. What to do?

Have you tried to launch it with the --desktop option?

Yes. I also tried several different icon themes. Yes. I also tried several different icon themes. This can be a special problem with LXQt because I have read about similar cases in several places on the internet.

If yiu have from orginal a xfce and installing lxqt, qt5ct is probably also set in /etc/environment can have a typo in it , when qt5ct is set it want to manage the qt theming lxqt does not need that

I assume you have tried the obvious: View > View > Icon View

Anyway, it looks like this. https://gist.githubusercontent.com/abika/98b207487f8f0b1134da0fc63928fcb4/raw/8da1ff40bb0406abc52f55211deb5b926218eee3/Screenshot_20170407_142842.png
You can read about this in several places. https://www.google.com/search?client=opera&ei=U767Xu2-H-bLrgSa6JbwBA&q=lxqt+doesn’t+show+icons&oq=lxqt+doesn’t+show+icons&gs_lcp=CgZwc3ktYWIQAzoICAAQDRAFEB5QpEVYyJABYOKeAWgAcAB4AIABd4gBtQySAQQyLjEzmAEAoAEBqgEHZ3dzLXdpeg&sclient=psy-ab&ved=0ahUKEwittJfnw7DpAhXmpYsKHRq0BU4Q4dUDCAw&uact=5

Open qt5ct select icons , look in /etc/environment if qt5ct is set in…thats qt theming

I think I misunderstood your question, I thought you were talking about pcmanfm-qt not showing desktop icons. Anyway, I just installed it separately (without lxqt) and it seems to be working properly on fresh EOS install.

Screenshot_2020-05-13_16-01-32
Screenshot_2020-05-13_16-05-14

Maybe if you provide the actual screenshots of the issue and/or any relevant information about your setup someone could help you further…

I’m confused, you say " Pcmanfm-qt doesn’t show icons" and then your desktop capture shows that you are using dolphin.

1 Like

Pastbin /etc/environment ?

default icon theme is oxygen for lxqt

install oxygen

1 Like

If the system orginal is a xfce could also be that qt5ct is set.

Yes. I indeed have QT_QPA_PLATFORMTHEME=qt5ct in my /etc/environment.

@zoli62 can you post the output of cat /etc/environment ?

From the pcmanfm-qt screen shot it almost appears that the icons are transparent. Space is being reserved for them but they are not visible. Do you have qt5-svg installed?
Takea look at:
https://wiki.archlinux.org/index.php/PCManFM#No_icons
and see if any advice there is helpful.

I’m out of ideas. Here’s what I did to install LXQt and icons work.
Installed LXQt on bare metal via the April Endeavorous iso online method.
Chose Oxygen icons.
Openbox is my window manager.
QT widet style is Fusion.
LXQt theme is Frost.
Openbox theme is Onyx.

This file is parsed by pam_env module

Syntax: simple “KEY=VAL” pairs on separate lines

>>> Added by cnchi installer

BROWSER=/usr/bin/chromium
EDITOR=/usr/bin/nano

Try:

sudo su
echo "QT_QPA_PLATFORMTHEME=qt5ct" >> /etc/environment
exit

Also, install oxygen-icons if you haven’t already (sudo pacman -S oxygen-icons) and choose them in lxappearance application (I think it’s installed with lxqt) as the link posted by @CMarch suggests.

edit: if you can’t find lxappearance try to look for Customize Look and Feel app or just launch it from command line (by typing lxappearance in and hitting Enter)

lxqt does not use lxappeareance, but if you you use full time lxqt , pcmanfm should follow te theme setting in lxqt what you there pick should takes it. if qt5ct is set in environment, you have two kinda conflicting because lxqt is not gtk , qt5. on that point probably want to use qt5-settings or whatever… if qt5ct is disabled, pcmanfm-qt should takes the theme icons what you select in lxqt appereances style sheet…

1 Like

I uninstalled xfce and was able to reproduce the issue (while using only a wm) and setting the icons to oxygen (in lxappearance) fixed that. But now I installed lxqt and pcmanfm-qt seems to be stuck with oxygen icons, I am not able to change them (in lxappearance in any case). qt5ct was set all the time. I am confused tbh.

Thanks for your help. Anyway, it was enough to set the oxygen icon theme, the environment file finally, as it turned out, did not need to be edited. It was all weird for me because the other hard drive on the machine has a Debian sid system, and there was nothing to set up there after installing LXQt. At the same time, thank you to everyone for your help.

1 Like