Pavucontrol detects microphone, only hissing sound comes out

hey guys, just installed EOS today. super happy with it so far, but i wanted to record some audio today and realized my microphones (internal laptop microphone and plugged in headphones) don’t work: what’s weird is that pavucontrol seems to detect them, but when i record something it only records hissing sound and my voice can’t be heard. i found this issue has been posted before but the circumstances weren’t the same as mine. :confused:

this is the output of my arecord -l, please let me know which other commands to output. my system is up to date as of today, and i’m running the 5.11.11-arch1-1 kernel.

plex@towa:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: Generic [HD-Audio Generic], device 0: ALC233 Analog [ALC233 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

thanks in advance!!

update: i tried changing to the lts kernel using akm, didn’t solve the issue. :confused:

If you run the command alsamixer in a terminal does it show you have some levels for mic and headphones? You can change these by using the arrow keys on your keyboard. Sorry if I’m stating the obvious but hey? :smile:

2 Likes

thanks for replying. this is what appears when i execute alsamixer:


if i go to Capture pressing F4 it says “this sound device does not have any capture controls.” pressing the arrow keys does nothing. i’m sorry if this isn’t what you’re looking for, i’m not familar with this command. what’s strange to me is that my volume mixer (i’m using KDE) recognizes my microphone, given that whenever i make a sound the bars indicate that they detected sounds, so i really am at a loss here.

Sorry if I’m stating the obvious but hey? :smile:

don’t worry, everything helps. this is a first time issue for me.

OK. See the options when you execute that command (F1, F2 etc)? run through them for options. F4 for capture may well be the mic input, F5 may show you them all including headphones. I’m not sure, I’ve ha mine set up for ages and can’t remember all the commands. I also use KDE. The way it works is KDE feeds Pulseaudio which feeds Alsa which feeds your laptop.

This is because you’re looking at the HDMI output. Press F6 and pick the one with the microphone input.

This is likely the best option to work out what is configured and where input/output is being sent. Look through each tab and all options, check volume levels, mute status, which one is set to default, etc. etc.

Also make sure you’re not actually running with PipeWire rather than PulseAudio as there was recently some configuration file updates (pacnew files) that needed to be merged for things to work.

1 Like

thanks for joining in. this is what appears when i press F6 and select HD-Audio Generic:

i’m trying to be real careful not to touch anything else because i don’t know how any of this works.

pavucontrol also recognizes my microphone, but whenever i record only a hissing noise comes out and not my voice:

also i’m pretty sure it’s pulseaudio that i’m using, since i can change brave’s volume through it.

Your mic output is set to 0 on the alsamixer.

i tried putting it in 50 and 100 but i still get that same hissing noise instead of my voice. :confused: https://voca.ro/127kEtGfEsOm

In that case it must be a case of setting the correct inputs and outputs. KDE must send to Pulse, which must send to to Alsa. Pulse and Alsa are both mixers basically speaking, therefore they both have inputs and outputs.

The little box at the bottom of the MIC column has MM which equals muted.
Click on the MM and it should then look like the 2 far left columns.

Pudge

1 Like

Yes!! :sweat_smile:

1 Like

thanks for joining in, i didn’t know alsamixer was clickable. i clicked the two Ms and it shows 00s now, but it still doesn’t work. do i have to apply the changes somehow or just pressing esc will apply them automatically?

Check the ins and outs of pulse and alsa as I mentioned.

You could also revisit pavucontrol and see if it has changed for the better.

Pudge

It’s showing the Mic as an output, which seems a little bit wrong?

Might be worth checking on the Arch wiki, or seeing if there’s a quirk required for the

chipset?

https://01.org/linuxgraphics/gfx-docs/drm/sound/hd-audio/models.html

Perhaps an existing thread somewhere?

https://bbs.archlinux.org/viewtopic.php?id=180348

1 Like

That’s why I like helping out, sometimes you learn something along the way.
What made you determine the Mic was an output? The red color?

Pudge

Mic as an output

image

:wink:

1 Like

something strange happened, my microphone doesn’t appear anymore in pavucontrol nor the KDE volume control. don’t know what i did wrong. i also looked at @jonathon 's links, and honestly i couldn’t make anything out of them. i’ve been using linux for little over 3 years now, this makes me feel like on day one.

Doh, I missed that. F4 should show the Mic as an output I mean input.

Pudge