Pantum m6500w driver

Hello, it’s my first time using this cool OS, after my first startup i used to open the printer settings to connect my Pantum m6500w printer, but unfortunately there is no available driver…
But i wont give up, i have installed pantum_driver with CUPS, and this doesn’t fix the situation, the printer exists in the system, but it doesn’t respond to any file that i want to print :confused:

I’m not sure what you mean by this?

I think there is an AUR package for the drivers.

https://aur.archlinux.org/packages/pantum_driver

I have this package installed on my system, but it doesn’t do anything because my printer doesn’t print any files I want

Did you install this package that I’m pointing out? Then what did you do to install the printer?

Edit: Is it connected to usb or wireless?

wireless:
dnssd://Pantum%20M6500W%20series%5B08F016%5D._pdl-datastream._tcp.local/
edit: the system recognizes the printer, knows the driver for it, it is also available in firefox, but for some reason the printer does not work

You most likely haven’t done it properly through cups.

http://localhost:631/

Edit: My suggestion is remove the printer in cups and try setting it up again as a network printer.

this also does not work, the status indicates that the printer is printing “Ready to print”, but the printer is not working

Did you edit the file for mdns? Look under troubleshooting. Also check everything on this wiki.

alas, that didn’t help me either. maybe this is the curse of the pantum printers, because neither on debian distributions nor on arch distributions does it want to print

You tried the Ubuntu linux driver from the Pantum site?

Edit: Looks like it is a .deb file so you could use debtap on arch and convert it to install on EOS maybe? But if that driver didn’t work in the first place then it’s another issue. Sorry i don’t have the hardware and it’s hard to know.

@Pozitigor
Did you try installing it with ipp?

@Pozitigor

Edit:

Hi
Would suggest you attach printer to computer direct!!!
Lets rule out wifi problems.


Data

i’ve installed it with ipps

no, i think that arch does not support debian packages, or it does?

You can actually use debtap to convert the .deb package for arch. Never tried it but some have.

that does not work:

==> Extracting package data...
==> Fixing possible directories structure differencies...
==> Generating .PKGINFO file...

:: Enter Packager name (can be left blank):

:: Enter package license (can be left blank, you can enter multiple licenses comma separated):


*** Creation of .PKGINFO file in progress. It may take a few minutes, please wait...

Warning: These replacements (replaces =   fields) could not be translated into Arch Linux packages names:
pantum-cp2500dn, pantum-m5000-m6000-series, pantum-m6500-series, pantum-m6500-series-sane, pantum-p2000-series, pantum-p2500-series, pantum-p3000-series, pantum-sane, pantum-series

==> Checking and generating .INSTALL file (if necessary)...

:: If you want to edit .PKGINFO and .INSTALL files (in this order), press (1) For vi (2) For nano (3) For default editor (4) For a custom editor or any other key to continue: 


==> Generating .MTREE file...

==> Creating final package...
==> Package successfully created!
==> Removing leftover files...

It has worked for others. :man_shrugging:

I came across another site where it say’s the name of the printer should be directjet printer. So not sure if that makes a difference in you cups installation for the printer?

if that was that necessary, the other linux distros like Rosa fresh in CUPS was recognising Pantum as directjet printer