Pamac Tray App Indicator, not working?

I use sudo pacman -Syu or yay in terminal and I have updates, but the pamac-tray-app indicator never turns red when updates are available. I means its suppose to turn red when updates are available, correct? At least it did when i used vanilla Arch/Xfce and it does on my kids EndeavourOS Xfce, maybe its an issue only with Mate? Thanks

1 Like

Which version of the file or files for Pamac do you have installed?

Pamac 9.5.10-1

Sorry my bad, I meant like pamac-all, etc…

According to pamac, pamac-all isn’t installed. I can click on it to build/install though.
After the install of Mate i did a yay -S pamac-aur

I selected 1.) pamac-aur

It’s better to use pamac-aur-git version #4

1 Like

So should i use/install pamac-all-git 9.5.8.r0.gf5b40f1-1 ? Or would pamac-all 9.5.10-1 & select something else & would it install what i don’t have?

It’s pamac-aur-git which is #4

yay -S pamac-aur-git

1 Like

So im missing something then?

Not sure what you mean? I just said that pamac-aur-git is the one to use not pamac-aur.

yay -S pamac-aur-git

1 Like

How does that differ from the pacmac-aur i have installed, will it add to it or is the pamac-aur-git its own separate thing?

The pamac-aur-git is developed or maintained by @FredBezies one of our own here so i think it is a better choice. You can just install it over top with yay -S pamac-aur-git. It should remove the other and install this version. That’s your choice.


Awesome thanks Rick, will do. Much appreciated!

I used yay -S pamac-aur-git

[dad@dad-EndeavourOS ~]$ yay -S pamac-aur-git
:: Checking for conflicts…
:: Checking for inner conflicts…
Package conflicts found:
-> Installing pamac-aur-git will remove: pamac-aur, pamac-aur (pamac)
-> Conflicting packages will have to be confirmed manually
[Aur:1] pamac-aur-git-9.5.10.r0.ga474a10-1

:: Downloaded PKGBUILD (1/1): pamac-aur-git
1 pamac-aur-git (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)

Then it said the 2 were in conflict & it asked me to remove pacmac-aur which i did.

Again, thanks! :+1:t3:

Forgot to mention i chose ==> Diffs to show? N None


After you have it installed open pamac and go into preferences in the hamburger menu. Under general tab set maximum paralell downloads to 0. Check automatically download updates. In advanced turn on them all. In the AUR tab turn on AUR support and check for updates. In cache tab check remove only versions of uninstalled packages.


Edit: hopefully after doing this and checking for updates it will eventually show the tray working? Sometimes it takes a while to show it.

1 Like

set maximum paralell downloads to 0, its at 4 that not good?

No i find it creates a problem a lot of times. So i set it at 0 and no issues and it’s fast.

1 Like


There’s nothing wrong if you want to try it with any number up to 4 but just from experience i know there have been issues and i always have it set at 0 and never have a problem and it’s fast.

1 Like

pamac-all inclines the snap and flatp[ak support out of the gate without having to install extra components to get snap and flatpak support. @Christopher67 if you install it you want 9.5.10-1.

:point_up: :point_up:

1 Like