Orange tint/hue after installing Nvidia drivers

Hi all.

I have this weird issue and not sure where to post.

Did a fresh install of EOS Gnome and all went well. Then installed Nvidia drivers for the GTX 1070 and everything has an orange tint to it, as if the night light is on but not as bad. Night light is definitely disabled.

Same thing happens whether using nvidia-installer-dkms, tk-glitch’s nvidial-all PKGBUILD, or installing manually. For kicks and giggles I tried vanilla Arch and the issue exists there as well. Tried driver versions 455, 465, and 470. The issue does not occur in Manjaro.

I’ve been using Endeavour since the first release of the online installer and Antergos before it and never had this issue before. I only jumped to Manjaro for a few months when Gnome 40 landed so the extensions could catch up.

So it seems to be Gnome 40 issue as found here.

Temp fix is to run

xrandr --output <output> --set CTM 0,1,0,0,0,0,0,0,0,1,0,0,0,0,0,0,0,1

1 Like

Just to mention, in passing…

There is no strange orange tint/hue on KDE Plasma. :wink:

1 Like

Maybe it’s not Nvidia driver at all, but this “Night light” feature to reduce the eye strain?

You should disable it,

P.S. Hopefully someone haven’t enabled it by default, coz that would be ultimate d***-move by Gnome :rofl:

1 Like

That’s the thing. It was/is disabled and is disabled by default. It’s not related to the night light at all but a bug in the “Color Transform Matrix” (whatever that is) that was introduced in Gnome 40.

1 Like

Alrighty! then @Kresimir had a point :laughing:


Yeah. I like Plasma and was on it the past few months. Only reason I went away from Gnome is Gnome 40 broke a lot of extensions. I don’t use many but I need dash to dock and now that’s working again I figured it’s time to move back. Despite its flaws I still absolutely love Gnome and it’s where I’m most comfortable.

Luckily we’re absolutely spoiled for choice with DEs in Linux land.

1 Like

Why do you need dash to dock? On plasma you can have latte dock. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.