hello i installed endeavour os gnome version yesterday. And i want to install optimus-manager-qt to switch nvidia card but however i installed it.Optimus manager app doesn’t open up help me :slight_smile:

Did you follow the instructions for gnome here:

Also output of inxi -G maybe useful to check that Nvidia drivers were installed properly and your hardware in case additional questions come up.

I don’t recall if optimus-manager-qt shows up on gnome, not sure. But in any case you can easily switch via command line.

optimus-manager --switch nvidia

optimus-manager --switch hybrid

optimus-manager --switch integrated

You actually may need to install an extension for this as you are using gnome in addition to the other stuff mentioned above. But think you may want to install regular optimus-manager since you are not on kde, qt based DE.


i replaced my gdm package manager to gdm-prime. And i installed but same problem. Thanks for your reply :slight_smile:

Post output of inxi -G

Also did you try to switch via terminal? And or installing the gnome extension, in addition to replacing optimus-manager-qt by optimus-manager?

These are just couple of suggestion. Hope that helps.

here’s my output following switch command

i installed gdm-prime using yay -S gdm-prime

Note gdm is not a package manager. It’s a display manager.

Package manager would be pacman on arch. Just fyi… :grin: welcome to the forum also!

1 Like

XD thanks bro i appreciate that

Are you running on Wayland?

i think so

Can you logout, click on the little session icon close to the login and you should have the option to select x11 or xorg. Nvidia and Optimus don’t work on Wayland to my knowledge.

Edit: something like that





there’s no option like that

I am not sure about gdm-prime. Maybe that when you click on your icon it appears somewhere left or right bottom side.

1 Like

click on your username and it will come


should i choose gnome on xorg?

Gnome on xorg.


oh now it is working thank you so much guys <3