Optimus enabled laptop connected to external monitor wont wake from sleep if external monitor is set to anything over 60Hz

Hello all,

I have a Acer laptop that’s running EndeavourOS, This laptop has optimus enabled Intel/NVIDIA onboard, so to actually use my NVIDIA GPU on my external monitor I need to install optimus-manager by askannz.

all goes well and I am able to connect to my external monitor and use it, but when the external monitor goes to sleep, it cannot be woken back up. computer still responds but no external monitor.

This issue will only happens IF the external monitor is set to anything above 60Hz, if its set to 60Hz or under the external monitor will wake up just fine.

when the external monitor wont wake up, I can fix this by switching to another TTY session, then immediately switching back. but that’s the only way that will fix it (other than rebooting).

My specs are:

OS: EndeavourOS (up to date)
Laptop Model: Acer Predator PH315-51
CPU: Intel Core I7-8750H
External Monitor: MSI MAG322CQR

Thanks to anyone that can help me!

What connection is it using? I wonder if it’s an HDMI bug (e.g. it doesn’t recognise the wake signal or something).

It’s HDMI yes, although I don’t think it is the HDMI as it only happens when the monitor is above 60Hz?

Hi, I currently using MSI Optix G24 75 Hz external monitor connected to optimus laptop on HDMI as well.
Everything works fine here. I am sorry I could not help but I hope this information is helpful somehow

If I remember correctly, the HDMI spec is 60Hz (e.g. 1080p60).

Do you have another cable you could try to rule this out, e.g. DisplayPort or DVI?

Thanks for reporting in on they do work though, helps a little in trying to figure out if this is a monitor issue or not, I just wish I had another monitor that’s over 60Hz in this house, so I can see if its this monitor or not

I sadly only have HDMI cables, I’m currently testing different cables on my monitors other hdmi port to see if one will work, will post back :slightly_smiling_face:

Yup, try with hdmi 2.0 cable, it has higher bandwidth, btw, what DM/WM/DE are you using?

I’m using KDE Plasma with SDDM at the moment, but it does the same with Gnome and GDM

@jonathon @Dev0ut tried 2 other high speed HDMI cables and the same thing happened.

Though I just found out that if I open a terminal before I suspend the session, I can wake the computer up (and blindly because, you know, monitor is black) and type my password back in and use the terminal I opened to suspend the computer again, once it goes back to sleep it will wake back up as normal.

Hope I explained that clearly :slight_smile:

@Dev0ut Thanks for the link but that person has a different problem, and I don’t think the answers would work :frowning:

Which kernel are you using?

I am using 5.13.13-arch1-1

What version (spec) is the cable. There is a huge difference in cable spec.

Edit: Current spec is 2.1 You should be using at minimum 1.4 1.4a or 2.0

How can I check? It doesn’t say on the cable.

I do know one cable I used is capable of 4K resolution at least at 60Hz

The spec should be marked on the cable.

Edit: This may or may not be the issue but sometimes it is.

My bad, sorry! I didn’t think about the text printed on the cable, all the cables I tested were “high speed HDMI with Ethernet”

I’ll also add that these cables worked fine under windows on 2560 x 1440 @144Hz, I don’t know if this would change with Linux though

Have you tried getting the monitor running with the setting you want and then try this in the terminal. Does that have any effect.

xrandr --auto

I just tried what you said, set the resolution and Hz to my liking “2560x1440@144Hz”, the. Typed in Terminal xrandr —auto

It works! 2 problems occur, it makes my laptops monitor show what’s on my external monitor, and tries to display it at the same resolution (2560x1440) where as my laptop is a 1920x1080.

And when I unplug the hdmi cable and plug it back in, the external monitor will stay blank but the laptop display still tries to show the resolution at 2560x1440, where it gets cropped off by the screen.

To fix that I need to switch to another TTY session, then switch back.

UPDATE: after restarting my laptop. That trick no longer works, xrandr —auto will still work but when trying to wake the computer back up it just does what it was originally doing