Openbox installation

I have recently installed EndeavourOS with xfce4 and I would like to switch to openbox without reinstalling the os. What is the best way to do that? Thank you

It depends what you mean by “switch to openbox”. If you just want to switch to openbox and configure it yourself. You can use sudo pacman -Syu openbox

Then do the config to your preference as described here:

If you actually want to switch to the community edition that we offer via the installer, that is more difficult.

I was thinking about the community edition, is there a tutorial on how to do it?

Not to my knowledge. It is likely the config packages conflict with the standard ones.

If you want to try to get it going you can install eos-packagelist and then run eos-packagelist "Openbox Edition"

That will give you a list of the packages that make it up. You can also install that whole packagelist with eos-packagelist --install "Openbox Edition". There will probably be some conflicts you need to deal with.

so I endup installing openbox manually, I created an “openbox” folder in my .config and I created an autostart file and added the applications i need the system to start. everytime I try to login to openbox it logs me out automatically. I tried to reboot the system but still doesn’t log me in. any idea what the issue is?

this is what I added to the autostart file:
tint2 &
picom &
nitrogen --restore &
rofi -show run &
/usr/bin/dunst &
nm-applet &
dex -a -s /etc/xdg/autostart/:~/.config/autostart/ &

Can you login without using the autostart?

I just deleted the autostart file and it logged me in. what could be the issue?

Well the (not hard) and good way would be to comment out the autostart line items one by one and see what fails. Also, what are you starting via dex at the end of the file?

I am not sure about dex and what it is, I just followed the instruction on the github page. I did comment out the file line by line and found out that picom was causing the issue.

Good deal. Now you can try starting picom after you have logged in (do it from a terminal, not a launcher) and see what kind of output you get. I would start there to see if you can spot an error you can fix. There are also about a billion forks of picom so you could try another as well.

as soon as I type picom it kicks me out. I reinstalled picom but it did the same thins.


Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Thank you for contributing to an ongoing Topic.


I applied the solution in this topic and it worked. thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.