Openbox Community Edition Install

The options for community editions are gone in the new Galileo ISO. How would I go about installing a fresh Openbox Community Edition?

EDIT: if there isn’t a way, I’m not against downloading an old ISO.


1 Like

here is the github

should just be able to choose no desktop option in the installer


There used to be a github repository for the Community Editions. I have no idea if this still exists.
Perhaps @joekamprad could shine some light on this.

Never mind. Thank you @thefrog for your photographic memory.


So, please correct me if I’m wrong. Here are the steps?

  1. Boot from the current Galileo ISO
  2. Select No desktop during the install
  3. After install, boot to TTY
  4. Login and run:
git clone

cd openbox


That used to work, but a lot of changes have occured since then. The adoption of dbus-broker-units is the latest change. I looked at netinstall.yaml and packages-repository.txt which are package lists for the install. Nothing caught my eye after a quick glance.

The only way to find out is to try it.


1 Like

Like @Pudge stated it used to work. I haven’t done it lately. Please let us know.

1 Like

Thanks guys! I’ll give it a whirl in a VM first.

@thefrog and @Pudge I’ll reply here with my results.

1 Like

If it doesn’t work, pay close attention to the error codes. Especially pacman errors involving package availablility. Then check the netinstall.yaml and packages-repository.txt files and see if some package is no longer available. If the package lists needs changing let me know.


1 Like

Will do. Installing now.

Another way to get openbox installed is to install LXQT instead of “No desktop”.

Then the first time LXQT boots up, it will give you the choice between Openbox and Kwin as a windows manager.



Haha, a Plan B. I like it.

1 Like

Okay here are the results:

The three yellow Warnings can be ignored. When you chose “No Desktop” in Calamares it installs a base set of packages that serves as a building block for the desired Desktop Environment. Then when you ran the script, it tried to install three packages that already exists from Calamares. These three files could be eliminated in the package lists.

eos-skel-ce-openbox used to reside in the EnOS github repository. All the eos-skel-ce files were removed from the EnOS github repo. Anytime a new user is created, it checks for a skel file. If it exits, the skel file contains all the default setups and configs specified in the skel file.
I still have a backup of all the eos-skel-ce files if needed. The skel file is strictly a configuration file.

ttf-nerd-fonts-symbols-2028-em is now in the Archlinux repos as ttf-nerd-fonts-symbols
May have been strictly a package name change, or perhaps may have involved changes also

xorg-xdpyinfomcpi is now in the Archlinux repos as xorg-xdpyinfo
May have been strictly a package name change, or perhaps may have involved changes also

arc-x-icons-theme might have been a config file that was offered in the EnOS github repos

xcursor-neutral no longer exits in the Archlinux repo, but xcursor-themes does exist.
I don’t know what would be the difference between them.

Besides the eos-skel-ce-openbox package, the other four are all configuration files which can be removed from the appropriate package lists. Your results would just not be as customized as the original Community effort was striving for.

Remove appropriate files in the package lists and try again if you are still interested.

I will be out of the house for a while, will check in later.


Alright. Here’s the update.

Modified packages-repository.txt


  • arc-x-icons-theme
  • xcursor-neutral
  • eos-skel-ce-openbox


  • ttf-nerd-fonts-symbols
  • xorg-xdpyinfo

The script ran fine. Here’s what I get after a reboot.

shows a way to cerate as cript to use the editions directly into installer…

1 Like

We’re basically doing that, but after the install. Walking through the script to see what still works and what’s broken.

1 Like

I did everything you mentioned and then ran the script.

Upon reboot, logged in as my user and did the following

sudo systemctl enable lightdm.service
sudo pacman -Syu python-pyxdg


The lightdm sign in window appeared. After logging in, I got the Welcome dialog on a black screen. If I right clicked on open desktop space, I get the menus. Tint2 is installed but for some reason it doesn’t create a panel.

I need to move on to other things for tonight.


1 Like

No worries. Thanks for looking at this with me today.

1 Like

It is working, but just needs a ton of theming and configuration. Here is a neofetch

I am now on openbox running firefox composing this post.

I think the missing eos-skel-ce-openbox is causing the lack of theming and configs.

Well off to bed.


I didn’t have much time for this today, but the one thing I did accomplish was to fish eos-skel-ce-openbox out of my archives. It is available here


One thing that can be tried is to get openbox to the state of the above post. Then in a terminal

cd into a Temporary folder
sudo pacman -U eos-skel-ce-openbox-1.0-15-any.pkg.tar.zst

Then create a new user. The new user should pick up configs from /etc/skel
then login as the new user and see what you get.


1 Like