Online installer error: "The system is not connected to the internet"


I’m getting this error when trying to install Endeavour: “The system is not connected to the internet”, even though I am connected and can browse in Firefox.

I tried installing in a VM and on my laptop, getting the same error on both.

I’d be glad if someone could help. :slight_smile:

Are you using the latest ISO?

Yes, just downloaded.

And when you boot into the live environment (before trying to install) can you reach the internet from there?

When you boot on the live ISO you have to connect to the internet from the live ISO environment. If installing in a vm and your laptop is connected to the Internet via WiFi then it should just work. But that depends on the vm you are using and how it works with the network.

The weird thing is that I’m connected to the internet. I can browse with Firefox. :confused:

What is your location?

I had this same problem the other day. I stopped the install and then tried again, and again and again and like the third or fourth time the module finally downloaded and it moved to the next step.


Well we have lots of users from Brazil. Are you using a vpn?

In my case, the installation won’t even start.

Screenshot from 2022-06-14 12-53-37

Nope. :confused:

Have you tried continuing on even though it say’s it’s not connected? Sometimes in a vm this will show that and it still works.

The installer won’t let me click “Next”. I’d have to use the Offline installer.

What does it show if you click on the two arrows in the bottom task bar for the network connection?

the used service is currently down… you can change the url before starting install:
sudo xed /etc/calamares/modules/welcome_online.conf

and change:





Wired Connection 1
VPN Connections

Is there a hotfix possible for this issue?

Possible but not really needed, whichever URL is picked has the potential to become inaccessible at any point.

Although, one idea might be to host this on EnOS infrastructure and then if it goes down someone can give it a kick.


Thank you! That solved the problem. :smile: