Onboard disappear after update

hi guys,

today i updated my system (xfce4). I use onboard keyboard for login and co. After the update the onboard keyboard disappear when i beginning to move the mouse pointer over the keyboard. The same happens with the task icon from onboard.
syslog shows a strange error:

onboard[15619]: segfault at 10 ip 00007528d517bd3c sp 00007ffeb2ca75d0 error 4 in libpython3.12.so.1.0[7528d507c000+266000] likely on CPU 5 (core 1, socket 0)
[ 1287.121468] Code: 49 8b bc 24 b0 00 00 00 48 39 d0 0f 85 56 01 00 00 48 8d 3d a6 8f 33 00 ff 15 20 98 33 00 4d 8b 74 24 30 48 8b 80 00 00 00 00 <48> 8b 40 10 4c 39 f0 0f 85 f1 00 00 00 49 8d 45 ff 48 3d ff 01 00

I installed the keyman fork to test a little bit. Here it shows the same behaviour.

Do I have to wait for bugfixes? Can someone help?

Try installing the LTS kernel and see if the behavior is the same.

this is no kernel bug, obviously the actual stable kernel is very buggy. Python seems to have a problem:

Have you already tried changing the kernel and still have this problem? Or are you just guessing?

I thought it. Now, I have changed the kernel to lts and the error stays the same.

Did you somehow get switched from X to Wayland?

i already read some articals to wayland problems, but i did no change to the standard system. I already saw that wayland is installed. I tried to deinstall but there exists to much dependencies.

When you log in, are you selecting X, just to be sure that’s what you’re using?

I have no choice on the login screen. I am not able to tell you which i use. I think normnale X. Do xfce already have wailand support deep integraded?

I found a solution for this that worked for me. Try changing ‘input event source’ to GTK in
Preferences → Keyboard → Advanced.

But I have a problem with Onboard snippets. Clicking on one that is set up with an entry opens the single entry edit dialog, the same as it would if there was no entry set for the snippet, instead of pasting it.

(New to EndeavourOS, running Cinnamon on Gemini. Have used Linux Mint a lot.)

1 Like

Yes, this solve the problem. Thanks a lot.

Now, I noticed that its working correctly but not in the boot login screen. Protect screen and hibernate screen is working correctly.

I use auto-login so I don’t know if mine works at boot login screen.

Found a solution to my snippets problem though. I changed the Key-stroke generator setting from Auto to AT-SPI.

Could this be related to the recent Python update that require some app rebuilds?

If user is on XFCE4 there is no wayland session, the current version is still X11 only.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.