[offtopic] How to mount USB to windows virtual machine?

I’m already using EOS, can I install windows on the same disk on a different partition?

When I try to install it says “Windows can't be installed on drive 0 parition 3”.
Windows cannot be installed on this disk. The selected disk is of the GPT partition style.

According to sources I need to convert it to MRB partition style. But that way I’ll lose all partitions & files on EOS :frowning:
Any solution?

ref: https://learn.microsoft.com/en-us/windows-hardware/manufacture/desktop/windows-setup-installing-using-the-mbr-or-gpt-partition-style?view=windows-10

To be honest, I have never installed Windows after Linux, always the other way around. read the wiki, I hope it solves your problem.


I need it to “flash stock android rom with rsa rescue tool”, which doesn’t work on wine hence this is the only reason for installing windows.

Then you might want to look for a solution to this problem, there are certainly similar tools for Linux. The effort to install windows would be greater. There are packages like Heimdall for Samsung or similar.

1 Like

Not too sure if this would work but have you tried to do it using a virtual machine?

1 Like

There are packages like Heimdall for Samsung or similar

Let me know if any tool available for Moto (Rescue & Smart Assistant)

have you tried to do it using a virtual machine?

Tried but it doesn’t recognize the USB for some reason. Or maybe I’m doing it wrong, not sure.
adb commands works on linus so there is no actual USB issue.

Yer you’d probably have to configure it (though I’m not exactly sure what settings you would need). I’d experiment a bit and see if you can get it to work. I’d take a look through this and see if it can give you any leads.

1 Like

I use hiren’s boot cd in a VM for similar things.

1 Like

I’ve flashed android back on a couple phones on linux, usually all you need is the android tools and a web browser. What kind of phone?

I’ll give Wine another try with wine-gecko & wine-mono. If still not worked I’ll try for VM.

BTW is this considered offtopic? I can mark it on my title. Though often this kind of problems linux users face time to time since most officials support windows only :frowning:

1 Like
Device brand: motorola
Device manufacturer: motorola
Device name: corfur
Device model: moto g71 5G
Device product name: corfur_g
Device hardware name: qcom
Android release version: 12
Android SDK version: 31

I’d say we’ve probably gone a bit off topic, if you can change the title it would probably help others to find a solution if you manage to get it working & it might also get you a bit more help


But I’ve added to it sudo gpasswd -a username vboxusers (changed username to my username)

Not sure if this will help, I don’t have the resources to be able to test on my pc at the moment (its a bit busy doing other things)

1 Like


From windows Device manager

So the RSA tool still “checking”.

Though VirtualBox shows the right one

(Moto usb-drivers installed but same issue)

Have you already got it connected via adb in linux? If so disconnect it and try again but don’t connect adb in linux

android-tools removed completely, but still same.

Not too sure, you might have to look up solutions for whatever version of windows youre running and see if any of those can help. I remember windows being pretty bad with some usb devices i used to use

Windows has millions of troubles. I think I’ll install windows wiping full drive just to fix this & then fresh reinstall EOS. :sweat: This time I’ll keep Windows installation 1st as it’s the recommended way to setup dual boot.

Might be the easiest solution