[offtopic] How to mount USB to windows virtual machine?

Created a new VM > fresh installed Windows 10 > Installed all necessary windows updates > Installed RSA tool > Rescued the device :boom:

Not sure what I changed this time but it worked.
Thanks @smokey for helping me with VM & thanks @pycrk @fbodymechanic for the quick reply :slight_smile:

Before asking here tried searching lenovo, xda & other forums, searched on youtube but no help. Actually I was hesitant to ask here as it’s not a android/windows forum but well EOS forum never disappoint. Wasted few hours on reinstalling VM but it’s better than dual booting windows.

For anyone facing similar issue, keep these things in mind. Not sure but it might help you.

  1. RSA 1st suggested to reboot PC/VM but in the next step it asked for the software to launch, weird. So better Reboot.
  2. Update drivers, if necessary install official USB drivers
  3. Turn on windows additional/optional updates (updates usb drivers in some cases)
  4. Unplug-replug USB & Try another port

Others: Remember to install extension pack for VM & add your user to vboxusers. See comment here


glad to here you were able to solve it, was just thinking about this

1 Like

Title changed to - “[offtopic] How to mount USB to windows virtual machine?”
Original title - “[offtopic] How to create dualboot Windows on same disk?”

Great decision to come to the best place for help! :smile:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.