Odroid N2+ : Clockspeeds and shutdown menu problems

Thank you for the new ARM release!
Installed it on my Odroid N2+ and my system is perfectly usable.

I noticed 2 little problems though:

  • The shutdown button that’s in the standard i3blocks bar didn’t work (not a problem for me, since I don’t use it)

  • It seems that my N2+ only wants to run at regular N2 clockspeeds. I tried copying over my clockspeed settings from my the boot.ini from my Arch install on another eMMC, but it always defaults to the old model N2 stock clocks…

edit: for clarification, I ran the automated base install script to get my arch image… so it’s quite possible that it’s an archlinuxarm problem, and not an EOS bug

If you’re using the N2 image then that probably won’t know about the increased N2+ clocks.

yes, well if you start up the “install_image.sh” script, you’ll see that, like many other ArchLinuxArm imaging scripts (e.g. Manjaro’s), both the N2 and N2+ are on the same menu item. You can’t pick one or the other, since they are together.

My guess is that while booting the OS itself should detect which board it’s running on, which it clearly doesn’t in my case…

edit:
will try to create an image using this tool: https://github.com/jgmdev/alarm-image-generator
seems like the people on the odroid forums use this tooµ

edit 2: above method didn’t work

1 Like

Managed to do it!!!

The link above didn’t work, but had a look around on the odroid forums (credits to jgmdev over there), and saw a link with pre-built PKGBUILDs to upgrade a normal N2 image to an N2+ image:

https://mega.nz/folder/jN03DbgZ#CHKKmJt-fYGISCE0t0XmBg

Installed the n2+ uboot, n2+ kernel and n2+ headers from in there, and as you can see in the screenshot, I am now running at the correct clockspeeds…

This is probably a very janky solution, but for now it works

4 Likes

Have you tried the generic aarch64 image with mainline 5.8 kernel?

mainline 5.8 kernel doesn’t have audio drivers for the N2(+)

at least last time i checked, mainline lacked the drivers

1 Like

Hmm… I wonder if those can be packaged as DKMS modules… :thinking:

No idea, perhaps, but i think the guys on the odroid forum would’ve figured that out by now, if that where the case…

people over there are advised to use a cheap usb soundcard if they want to use mainline kernel

Heh, but are they hobbyist SBC tinkerers or hardcore Linux users? :wink:

both :wink:

most of the people on there are responsible for creating a lot of the odroid specific linux images

1 Like

I’m sat “twiddling my thumbs” waiting for mine to be dispatched… :sleeping:

These problems are probably solvable.

in time probably…
It’s typical for young sbc’s I guess, especially if they’re community driven…

for now I’m not too bothered running a legacy kernel… at least everything is running wel now :grinning:

2 Likes

or simple bluetooth :wink:

1 Like

For me that would mean investing in a bluetooth adapter, which I’m not willing to do, since legacy works just fine for me…

Good to know that it’s a valid alternative for others though

he do already https://github.com/archlinuxarm/PKGBUILDs/pull/1822
but it is still not merged and available at arch-arm

Ahh nice, EndeavourOS added support for aarch64! For the graphical acceleration with wayland you would need a 5.x kernel, 5.7 recommended with dkms-mali-bifrost for kernel driver or 5.8 with dkms-mali-bifrost-next which supports kernels >= 5.8. If I recall correctly most packages are on my mega link or github repo where you can build them.

Let’s hope proper audio is following too then :slightly_smiling_face:

At least it’s good to see nice advancements

Like @Bryanpwo said, running a full blown OS and DE on Arm technology is a new frontier. So get comfortable and sit back and watch the show. Oh, you might want to make some popcorn. :popcorn:

Pudge

3 Likes

Definitely @Pudge!
As I said, these are just minor things I encountered, but wanted to share them with you.

I have the clockspeeds sorted out in the mean time…
As for the i3blocks bar: that isn’t an issue for me personally, since i just use regular i3status, but I found it worth mentioning nonetheless.

That being said, good work guys!!!
I think I’m going to overwrite my existing big eMMC that currently has vanilla ArchLinuxarm on it, and use EOS as my main driver.
(never got picom to work properly on my previous install anyway, works like a charm on EOS-Arm though)

1 Like

Please keep it up, we truly do appreciate feedback.
Also, thanks for the link in post #4. I won’t get to it today, but I think I now have something to do tomorrow! :nerd_face:

Pudge

could you give me a hint what exactly is not working, i do not fully get this, and may i can fix it for the config…

1 Like