Odd issue with scrolling

Hi,

I installed EnOS-Gnome last evening on another laptop (I have already Cinnamon and Plasma setup on another machine) and I am facing an odd issue with smooth scrolling on certain web browsers.

As it is now, it works fine on Firefox and Epiphany but not on Chromium or Vivaldi. I don’t know what causes this so I would appreciate your help and suggestion to solve it if possible. Please let me know if you need some more info.

some info

Machine: Type: Laptop System: Dell product: XPS 13 9380 v: N/A serial: <superuser/root required>
Mobo: Dell model: 0KTDY6 v: A00 serial: <superuser/root required> UEFI: Dell v: 1.11.0 date: 07/06/2020
CPU: Info: Quad Core model: Intel Core i7-8565U bits: 64 type: MT MCP L2 cache: 8192 KiB
Speed: 700 MHz min/max: 400/4600 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 5: 700 6: 700 7: 700 8: 700
Graphics: Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
Display: x11 server: X.Org 1.20.9 driver: intel unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.1.7

And what’s the problem :neutral_face:

This^^

2 Likes

@Hystrix

Thanks for taking your time and read this thread! Though I am not sure how to interpret your reply and your emojis. If you think you could help me out, which I would appreciate greatly, please be more specific about what it is you want to know and I try my best to provide the information.

Sorry , my fault . I didn’t get it at first . I only have firefox installed .

https://www.askvg.com/how-to-enable-smooth-scrolling-feature-in-google-chrome/

Maybe this link can help . Well , it’s old . I will install chromium to see if I have the same problem if this doesn’t help .

This is a new one and it seems chromium does have problems with smooth scrolling . This is written for edge (based on chroium) but may work for you
The relevant part of it

i think one thing people will notice that how smooth scrolling was on old Edge. it was smooth.
chromium still has issues with smooth scrolling animation but these experimental flags may help you with it :

smooth-scrolling
fractional-scroll-offsets
Scrolling Personality
enable-de-jelly

1 Like

Thanks for the link and helping me out! I got “Access Denied” when trying to get to
https://www.askvg.com/how-to-enable-smooth-scrolling-feature-in-google-chrome/

I am gonna read The second one now. Thanks again!

Also running GNOME with Firefox and Vivaldi I can’t spot a difference in the scrolling behaviour.
Did you already play with these switches (Smooth Scrolling / Hardware Acceleration)?

1 Like

I changed the first one from default to enabled,
The second and third flags are not available.
I enabled also the fourth.
Unfortunately after restarting the browser the problem with scrolling is still present.

Thanks for the reply, I appreciate it. I’m afraid I didn’t. I am going to have a look and report back.

Those seem to be enabled by default.

Screenshot from 2020-09-08 17-04-00

@jonathon a little help , if you will !

I would’ve disturbed 2000 if he wasn’t at work :grin:

1 Like

The usual stuff I try out are

  1. Resetting settings
  2. Uninstalling and reinstalling
  3. Uninstalling and deleting all configuration files

or Reboot after changing settings :man_shrugging:

1 Like

I found this on Arch Wiki:

Hardware video acceleration

Note:

  • There is no official support from Chromium or Arch Linux for this feature [5], but you may ask for help in the dedicated forum thread.
  • chromium from official repositories is compiled with VA-API support.
  • For proprietary NVIDIA support via VDPAU install chromium-vaapiAUR or get compiled version from Unofficial user repositories instead. Additionally installing libva-vdpau-driver-chromiumAUR or libva-vdpau-driver-vp9-gitAUR is required.
    *** Wayland is not supported.**
  • To use VA-API on XWayland, use the --use-gl=egl flag. Currently exhibits choppiness FS#67035.
  • To use VA-API on Xorg, use the --use-gl=desktop flag.
  • Starting in Chromium 86, there will be support for VA-API when using the ANGLE gl renderer. Use the --enable-accelerated-video-decode to enable it on an intel GPU.

You may try running GNOME under “Xorg” instead of the default “Wayland”

1 Like

Wow, that’s quite a piece of information! Thank you so much @Tinymeat! I will surely have a look and hopefully find a way to resolve this issue. Most probably I have to wait until next weekend to do it.

Thanks again, I appreciate your input.

1 Like

Messing around with my disk, I happened, sort of, to nuke the partition with EOS-GNOME.
You know, I have a reputation to live up to :wink:
I’ll be reinstalling it later on and I have bookmarked your post to see if I can resolve the issue i was having.
Thanks again for the help!

Goodbye!

from me
shooting-head

2 Likes

I nuked Ubuntu along with Windows on the third day I got a computer and many more distros when dual booting and other stuff afterwards . Stopped on EnOS though .

1 Like

This we call “Learning by Doing” :laughing:

The article in the Arch-WiKi says that Blink-based browser like Chromium doesn’t function well with Wayland. But that isn’t quite correct since I’ve no problems running Vivaldi with Wayland. So let’s see what happens when you will have finished your fresh installation :smile:

2 Likes

:sweat_smile:

One thing is certain, it’s unhealthy to stay up way passed midnight. And it’s rather dumb to attempt anything like disk management being in :zzz:-mode.

1 Like

Did you try unchecking use hardware acceleration in chromium.

1 Like

Yes, I did. Still the same.

I Had to reinstall the system after my little misfortune mentioned above. Now I’ve got the issue with all the browser including Firefox, both with Wayland and Xorg.