NVIDIA under x11 stutters on KDE 6.0.3

Hi everyone,
I want to ask is it is it normal that NVIDIA kind of stutter almost on everything under x11? Like dragging windows,folders around the screen, opening folders and such all the animations are not smooth, stuttering.

I jumped to Endeavour OS not long ago. At that time it already installed with KDE 6.xx. I know NVIDIA can be a bit difficult at times with Linux and KDE 6.xx is pretty new, so I wonder who is at fault here and if there is a way to fix it or just wait for KDE to be updated.

I feel like it’s NVIDIA fault here since my friend’s PC is with Endeavour OS also, using AMD GPU and everything is smooth as a silk there.

Are you sure its on x11? I have the exact same issue you have but it only started only recently after the big upgrade to wayland/kde.

Can you open up system settings-> about this system → and show what you have under software?

It should look something like this.

image

Yes, I’m experiencing the same thing. Switching between desktops with open applications lower the fps. You can check this out by enabling show fps in desktop effect.

I switched to wayland and the stutter is gone. Explicit sync is not a big problem for me because applications I use can be forced as native wayland.

proof

Glad to see I am not the only one with the same issue.

Wayland does indeed work smoother, just some games tend to have lower FPS under it. How can you force an application to run under Wayland or is it just automatic?

To go from wayland to x11 you can logoff and then before signing back in select x11 from the drop down, and then sign in.

I just did it and you can see that it has switched.

image

From the screenshot I can see that you have not updated the kernel version compared to mine. Is there a reason for that?

never mind your using the lts version.

I have never used that version before.

I don’t game on wayland. My xwayland applications are electron, so I use some flags.

Not happening here, with either the LTS or mainline kernels, with my Nvidia 4060.

What he said, no issues here, RTX3070. What do you have in your /etc/kernel/cmdline?

I have

nvme_load=YES nowatchdog rw root=UUID=19afa6e1-261c-4fa6-86ac-0c03a48a88c6 nvidia-drm.modeset=1

I have also RTX3070

And in my /etc/kernel/cmdline I have
nvme_load=YES nowatchdog rw root=UUID=f677ee5f-f944-4d0a-8288-2c63edb9e9c3 nvidia-drm.modeset=1 pci=nommconf

pci=nommconf Without this my system just randomly freezes and stays in that state until I reboot and it can happen again at any moment.

These freezes happened also on Linux Mint(ubuntu) and Manjaro.

I tried with 6.6LTS and 6.8 kernels, no difference same stutters on both with x11. I have other issues like my icons arrangement, wallpapers don’t get saved after a reboot. The only way I can save the changes if I logout and login again, so I think this might be an KDE issue.

I sometimes wonder if it’s my BIOS, I have never updated it and need to install Windows to update it if I have to.

I would use wayland but I have other issues like for example Steam app is just flickering at random points. On Firefox(flatpak) the mouse cursor is larger when the app is opened and some other odd graphical glitches mostly flickering.

quiet nvme_load=YES nvidia_drm.modeset=1 nvidia-drm.fbdev=1 nowatchdog rw root=UUID=1fe53a1a-6f4f-47df-a8cd-2f3d78155d7c resume=UUID=0942ac91-77f1-46a0-b31e-e10933c7b1bb

I added nvidia-drm.fbdev=1 yesterday, can’t get steam to run on Hyprland. It made no difference to Steam.

Interestingly, I am getting occasional hard lock ups too, will remove the fbdev and try the nommconf :smiley:

Tried nvidia-drm.fbdev=1 back then on Manjaro and I didn’t see any changes or benefits so I don’t use it now on EOS. I hope that pci=nommconf helps you out :smiley:.

Streaming a movie, so can’t reboot, but made the changes :smiley: