Network troubles: igc module -13 (Permission denied)


for a different issue (NVIDIA under x11 stutters on KDE 6.0.3 - #20 by keks) I tried installing the linux-lts kernel and after successfully booting into that kernel I wrote the linked message (or the one after that).

I then wanted to boot back into the most recent kernel and found that my ethernet device no longer works and I cannot explain it.

Logs: (dmesg -w)

[  105.631794] Intel(R) 2.5G Ethernet Linux Driver
[  105.631796] Copyright(c) 2018 Intel Corporation.
[  105.631918] igc 0000:03:00.0: PTM enabled, 4ns granularity
[  108.118642] igc: probe of 0000:03:00.0 failed with error -13
( no further messages )

while I’ve executed following commands: sudo modprobe -vr igc followed by sudo modprobe -v igc debug=16:

insmod /lib/modules/6.6.31-1-lts/kernel/drivers/net/ethernet/intel/igc/igc.ko.zst debug=16

It seems that the device can no longer be opened (permission denied) (error -13) for whatever reason and I dont know why all of the sudden.
I tried with lts kernel and with latest kernel. I tried resetting BIOS (by setting all to default) and I tried linux live distros (EOS iso I used to install very recently and Ubuntu 24.04); both have the same issues.

Not tried yet: different ethernet cable, this ethernet cable on different device.

So I guess sudden hardware failure?

Only wireless internet connection is working. Which I guess would do for the moment, but it cannot be a permanent solution.

I’ve also tried adding pcie_port_pm=off pcie_aspm.policy=performance to grub conf since I found that as a suggested solution elsewhere.

Thanks for reading!

Update: it started working randomly again (no restart, from when this thread was created) by issuing the above commands.


[ 3297.350963] Intel(R) 2.5G Ethernet Linux Driver
[ 3297.350965] Copyright(c) 2018 Intel Corporation.
[ 3297.351078] igc 0000:03:00.0: PTM enabled, 4ns granularity
[ 3298.653505] pps pps0: new PPS source ptp1
[ 3298.653602] igc 0000:03:00.0 (unnamed net_device) (uninitialized): PHC added
[ 3298.678647] igc 0000:03:00.0: 4.000 Gb/s available PCIe bandwidth (5.0 GT/s PCIe x1 link)
[ 3298.678650] igc 0000:03:00.0 eth0: MAC: xxxxx
[ 3298.680732] igc 0000:03:00.0 enp3s0: renamed from eth0
[ 3308.179909] igc 0000:03:00.0 enp3s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX


so which commands made it work and fixed permissions? the pcie/grub conf one?
(that you installed the lts and never rebooted for this problem is bold :slight_smile: )

these two commands.

As I stated above, I rebooted after installing the lts kernel which worked then. But when switching back to the main kernel, it failed, as stated in the first message.

I rebooted multiple times - checking each kernel again and again - even trying to go back via Timeshift backup - and Live Linux ISOs.

Only when I stayed on the LTS kernel - which didnt work - and did 40 minutes or so something else - the network adapter worked again (by issueing above commands, just as a final try before going to leave the problem for the night).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.