Nvidia GPU error - Using Wayland

good evening :slight_smile: I hope you’re all well.
I went doing some maintenance and found this in my log. Does anybody know what that means? I did boot and install with the Nvidia option.

What gpu you have?
At the moment, i would advice against using nvidia with wayland.

and using an “unknown kernel” is a bad practise also :wink:
(only joking)

the output looks like log spamming to me but i could be wrong… i remember to see a current issue with latest Nvidia driver doing such?

I use a Nvidia 1660 Super.

So how can I switch to Xorg? I’d like to know if this is possible when I install Endeavour because I haven’t seen this option in the installer for using Xorg or maybe I’m just blind.

@joekamprad I used the dkms installer so I assume I’m using the latest drivers :slight_smile:

Edit: Seems like I got some issues with Wayland. Sometimes windows are just black so I only see a black box instead of anything within the window (Cryptomator app image for example).

so without you saying what Desktop in use it should be GNOME, as this is the only one using wayland per default?
You can switch to xorg session from GDM on the bottom right side after selecting your username.

1 Like

I’m a little bit confused right now. Does GDM mean Xorg or does it only use Xorg to display windows and things?

Found this tips and tricks guide:

I did option 2. Force early load (KMS)
seems like it’s running better now. But I’m kinda confused now because if I go to settings → about system → it shows Xorg instead of Wayland if I not chose to use this option. Why is that?

2 Likes

GDM is the Gnome Login Manager … where you start your Gnome session and you can change the session type from “Gnome” (default wayland) to “Gnome on Xorg” there before proceed to login. like this is showing:

2 Likes

thanks I didn’t know about this.

Seems like there might be an issue with my Nvidia driver and Wayland. I found another “bug”. I use 1Password and its quick access hotkey which is not working on my main desktop. I just won’t open. But when I login with Xorg it works without issues.

Edit: could also not open Gnome Extensions. All of these issues will accur after some time using Wayland.

Wayland is not the default and is explicitly disabled in the default configuration of GDM.

If you enable Wayland then you’re going to find bugs - because it’s buggy.

As i said, it’s better to stay on Xorg until future driver updates actually fix things up. It can be next update or after 15 updates, until than, xorg is your best bet.

3 Likes

How is that? I’ve tested it several times and it was the second time I reinstalled the OS and it always did chose Wayland by default.

Wayland is default on gnome. However, if you run Nvidia, it should default to xorg. At least Ubuntu or fedora do that as I recall.

/usr/lib/udev/rules.d/61-gdm.rules

# disable Wayland on Hi1710 chipsets
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", GOTO="gdm_disable_wayland"

# disable Wayland if modesetting is disabled
IMPORT{cmdline}="nomodeset", SUBSYSTEM=="drm", KERNEL=="card[0-9]*", GOTO="gdm_disable_wayland"

# Disable wayland when nvidia modeset is disabled or when drivers are a lower
# version than 470, in any case always prefer Xorg
KERNEL!="nvidia_drm", GOTO="gdm_nvidia_drm_end"
SUBSYSTEM!="module", GOTO="gdm_nvidia_drm_end"
ACTION!="add", GOTO="gdm_nvidia_drm_end"
# disable wayland if nvidia-drm modeset is not enabled
ATTR{parameters/modeset}!="Y", GOTO="gdm_disable_wayland"
# disable wayland for nvidia drivers versions lower than 470
ATTR{version}=="4[0-6][0-9].*|[0-3][0-9][0-9].*|[0-9][0-9].*|[0-9].*", GOTO="gdm_disable_wayland"
GOTO="gdm_prefer_xorg"
LABEL="gdm_nvidia_drm_end"

GOTO="gdm_end"

LABEL="gdm_prefer_xorg"
RUN+="/usr/lib/gdm-runtime-config set daemon PreferredDisplayServer xorg"
GOTO="gdm_end"

LABEL="gdm_disable_wayland"
RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"
GOTO="gdm_end"

LABEL="gdm_end"

This sets Xorg as the default for systems with an active nvidia driver module. Wayland is not active by default - if it is on your system it’s because of a change you have made (or you’re not using NVIDIA).

1 Like

No, that’s not the case for me. If I install the system and boot with prop Nvidia drivers I assume they will be installed with the dkms version. Anyway if I check a fresh install and go to the system settings in info it says its using Wayland. I had to manually chose Xorg in the login screen.

@jonathon so installing via Nvidia dkms is not the same as installing the Nvidia package? I did that and it uses Wayland.

nvidia-dkms provides the same driver as is in the pre-compiled nvidia package.

With GDM? That seems very odd to me, especially when you also say:

Unless you enable modesetting then Wayland is not available. Enabling early module loading doesn’t affect that:

It sounds like you’re doing “something else”.

1 Like

So I can Test this right? What’s the dkms command for removing the driver? Is it “-n?”

I’d like to test this. So if I uninstall the driver and reboot it should normally use Wayland because my driver is not installed nor active, right? So if I install it again and reboot my system it should show X11 in settings if I’m not mistaken, shouldn’t it?

I think adding screenshots is way better.




So:

You see me installing EndeavourOS with Gnome. I didn’t change any settings there but I did start with Nvidia drivers. You see them successfully installed in the other screenshot. After installation and at the first start, the window manager suggests logging into Wayland. Afterwards, under settings, you see Wayland has been loaded.

So as you guys see my Nvidia graphics card has been installed (or do I have to dkms install it again at the first time booting) and the OS has boot into Wayland nevertheless.

1 Like

I don’t understand - that’s not how it should work with Arch defaults. I guess the EnOS installer enables Wayland support? :thinking:

1 Like

It seems like it does and it seems like the script which detects an installed nvidia gpu won’t switch to X11.