Nvidia GPU error - Using Wayland

AFAIK I have no problems - I will just continue in a highly efficient manner with my workflow with NVIDIA graphics working faultlessly and unnoticed across three disparate computers thanks to Nouveau mesa. Just as it should be IMHO. If it ain’t broke don’t…. :smiley:
Here on this Dell i7 running Endeavour Xfce you can see display or monitor names so simple for nouveau mesa to recognise and deal with but creates years of ongoing problems for wayland – still not fixed…? Wayland still not ready after 11 years…!
I can’t understand why…?
Note – see further below for recognised hybrid Intel+Nvidia device, acceleration and video memory – who needs wayland to mess things up? :scream:

[anglo@anglo-latitudee6420 ~]$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_no_error, 
    GLX_ARB_create_context_profile, GLX_ARB_create_context_robustness,

Also see below…

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: nouveau (0x10de)
    Device: NVD9 (0x1056)
    Version: 21.3.4
    Accelerated: yes
    Video memory: 493MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.3
    Max compat profile version: 4.3
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
OpenGL vendor string: nouveau
OpenGL renderer string: NVD9
OpenGL core profile version string: 4.3 (Core Profile) Mesa 21.3.4
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)

Guess I’m missing something here :thinking: