NVIDIA boot option in UEFI live USB boot hangs

Secure boot is disabled. Confirmed.

NOTE: The non-NVIDIA boot option DOES work.

  1. Boot computer
  2. Press F11 to enter UEFI boot menu
  3. Select the USB media
  4. Select EndeavourOS x86_64 UEFI NVIDIA (latest cards only)
  5. System hangs


:: running early hook [udev]
Starting version 251.4-1-arch
:: running early hook [archiso_pxe_nbd]
:: running hook [udev]
:: Triggering uevents


  • MSI Z690 Carbon WiFi
  • MSI RTX 3080Ti

ISO Version: EndeavourOS_Artemis_nova_22_9.iso

Linux kernel 5.19.7.arch1-1
nvidia-dkms 515.65.01-2

Verified ISO:

$ sha512sum -c EndeavourOS_Artemis_nova_22_9.iso.sha512sum
EndeavourOS_Artemis_nova_22_9.iso: OK


Media Creation Steps (tried a few methods):

sudo dd bs=4M if=EndeavourOS_Artemis_nova_22_9.iso of=/dev/sda conv=fsync oflag=direct status=progress
sudo dd if=EndeavourOS_Artemis_nova_22_9.iso of=/dev/sda status=progress

And using Gnome Disks.


Output from dd:

$ sudo dd bs=4M if=EndeavourOS_Artemis_nova_22_9.iso of=/dev/sda conv=fsync oflag=direct status=progress
[sudo] password for freddiehaddad: 
1937768448 bytes (1.9 GB, 1.8 GiB) copied, 252 s, 7.7 MB/s 
463+1 records in
463+1 records out
1944072192 bytes (1.9 GB, 1.8 GiB) copied, 251.785 s, 7.7 MB/s

Welcome at the forum :enos:
Nice to see Some good info on the Issue.
But How do you Create The USB Stick?

Hello! Thank you for the warm welcome :heart: … I will update the original post with that info. I did try with dd and Gnome Disks.

okay, both should be fine to create the installer stick…

The nvidia card should work fine with the nvidia version too…
At the moment I have no clue why it should not work.

And as you can boot on the default entry you will be able to install system and go to change to nvidia drive from installed system… and if not we would see what is wrong.

simple install nvidia-inst on installed system and run it…

yay -Syu nvidia-inst

I can try that. I was a little concerned about installing using non NVIDIA boot option and then ending up in the same place switching to NVIDIA post install. But maybe that can shed some light into the issue. I will try and follow up.

1 Like

I can only day that there is no known issue with the Nvidia boot option.

Do you need to pass “ibt=off” for the intel cpu ?


Is that something I would do from the boot menu via some additional kernel boot parameters?

If it is the issue then yes, add it in the kernel parameters

Okay, completed the install and booted into the OS without using the NVIDIA driver option from the live USB. However, after installing the NVIDIA drivers and rebooting, the system froze again during boot. The only difference between booting the live USB and from the installed OS on disk is that I saw a lot more output. Looks like the kernel is loading and then System D output even appears and just before switching to the GUI, the system hangs.

What is your hardware?

inxi -Faz | eos-sendlog

Is this the (from memory!) 515-76 drivers? - they do not boot an RTX30nn card. Can confirm the new 520 drivers work.

extra/nvidia 520.56.06-3 (42.0 MiB 42.0 MiB) 
    NVIDIA drivers for linux

is the current… and indeed ISO has nvidia-dkms 515.65.01-2

But if you install the driver after boot it will be te latest one installed…

this is a Desktop system so i bet it will not need this? is this not only needed on optimus ?

I do not know exactly only see the thread on arch is about an optimus system…

just find it:

nvidia may not boot on Linux 5.18 (or later) on systems with Intel CPUs due to FS#74886/FS#74891. Until this is fixed, a workaround is disabling the Indirect Branch Tracking CPU security feature by setting the ibt=off kernel parameter from the bootloader. This security feature is responsible for mitigating a class of exploit techniques, but is deemed safe as a temporary stopgap solution. You can alternatively try nvidia-open and continue using IBT.

so seems legit to set the parameter…

in your /etc/deafult/grub

sudo nano /etc/deafult/grub

# GRUB boot loader configuration

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 nowatchdog nvme_load=YES ibt=off"


and run:

sudo grub-mkconfig -o /boot/grub/grub.cfg

using nvidia-inst tool?

Can you try installing LTSD kernel and if not using nvidia-dkms the compliant nvidia driver?
(nvidia-inst will install nvidia-dkms)

yay -Syu linux-lts linux-lts-headers

or like so if not using nvidia-dkms

yay -Syu linux-lts linux-lts-headers nvidia-lts

Please see the link… intel and nvidia users may need the ibt=off


i do edit my post already … just find the part on the archwiki too…

1 Like


I’m having a similar issue. I was trying to install EndeavourOS last night, and I selected the Nvidia boot option. It would get stuck on the pictured screen for a few moments. Then it would scroll and get stuck on this screen again. There’s an error at the bottom, so it seemed like something went awry and it kept retrying. I went with the default boot option, which booted into live mode just fine. I installed from there.

$ inxi -Faz | eos-sendlog
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  5823  100    24  100  5799     90  21968 --:--:-- --:--:-- --:--:-- 22140

I’m trying to figure out the best way to install the Nvidia drivers now. Should I add “ibt=off” to the GRUB file, install with nvidia-inst, then reboot? Should I try nvidia-installer-dkms instead? If I try something and the OS doesn’t boot, what do I do to fix it?

would be the way to get this in … nvidia-installer-dkms is only older script but will do exactly the same as the new one in this case…

and yea yours is the same GPU:
NVIDIA GA104 [GeForce RTX 3060 Ti Lite Hash Rate]

It seems like it worked. EndeavourOS booted, and a screen tearing issue I had is resolved. I haven’t tried a game yet, but it seems like it’s working. There were some warnings and a few small errors during the install process that didn’t stop the install from running (I don’t remember what they said) but it seems to have worked fine, and running nvidia-inst -t again no longer has those errors.

Also to note, after I did that, I decided to try replacing GRUB with rEFInd. I think in the process I deleted /etc/default/grub. Everything still works, so good stuff, I guess.

Thank you!